12 Replies Latest reply: Mar 14, 2012 5:26 AM by Mark Sheraton RSS

    Large file failing to reload

    Mark Sheraton

      We have a large (over 10 GB) qvw document which fails to reload when run as a task from the management console.

      The error file is attached. I am guessing the task has some timeout limit associated withopening the document.

       

      Does anyone know wherethis is or any other possible cause?

       

      Cheers

      Mark

        • Large file failing to reload
          Staffan Johansson

          Hi Mark, are you load data from a network drive or a fileshare? then use the relativ search way like \\ instead of D: in the application.

          • Large file failing to reload
            Jerry Svensson

            It seems to fail because you have Section Access in the application and haven't added user and pwd in your distribution task.

            "The document might require username and password"

              • Large file failing to reload
                Mark Sheraton

                The document has no section access.

                My hunch is there is a timeout limit for opening a document which is being reached.

                If I open the document in the thick client it takes about 2 minutes to open.

                 

                To prove the size of the file is casuing the problem (not the script) I did a data reduciton and tried again and it worked.

                 

                I've logged this with Qliktech but thanks anyway.

                • Large file failing to reload
                  Staffan Johansson

                  Add the user that runs the qlikview services as admin in your section access.

                    • Large file failing to reload
                      Mark Sheraton

                      The error message is a red herring.

                      Like I said, I've ran exactly the same document with less data sucesfully.

                        • Large file failing to reload
                          Mark Sheraton

                          My workaround is to load from a copy of the same dashboard with no data attached.

                          Detail below.

                           

                          Starting point

                          HCM_AD_OPS_MAIN_ALL_DATA.qvw (10 GB)

                          HCM_AD_OPS_MAIN_ALL_DATA.qvw.NO_DATA (Same as above but with no saved data)

                           

                           

                          Task 1

                          Step_1.qvw

                                    executes a bat file:

                                    Copy "HCM_AD_OPS_MAIN_ALL_DATA.qvw.NO_DATA" "HCM_AD_OPS_MAIN_ALL_DATA.qvw.NO_DATA_TEMP"

                           

                           

                          Task 2

                          Step_2.qvw

                                              executes a bat file:

                                              MOVE /Y "HCM_AD_OPS_MAIN_ALL_DATA.qvw.NO_DATA" "TEMP_DO_NO_USE_HCM_AD_OPS_MAIN_ALL_DATA.qvw"

                           

                           

                          Task 3

                                    Reloads TEMP_DO_NO_USE_HCM_AD_OPS_MAIN_ALL_DATA.qvw (Opens fine as no data attached)

                           

                           

                          Task 4

                                    Step_3.qvw

                                              Exclutes a bat file:

                                              Move /Y "TEMP_DO_NO_USE_HCM_AD_OPS_MAIN_ALL_DATA.qvw" "HCM_AD_OPS_MAIN_ALL_DATA.qvw"

                                              Rename "HCM_AD_OPS_MAIN_ALL_DATA.qvw.NO_DATA_TEMP" "HCM_AD_OPS_MAIN_ALL_DATA.qvw.NO_DATA"

                    • Large file failing to reload

                      I'd like to add that I am experiencing the same issue in QV11.  We have a 3GB Qlikmart that fails with the same error message. No section access in any of our documents.

                       

                      I tried using the local client and it seemed to work fine.

                       

                      Next I reduced all data in the Qlikmart, and it worked fine in publisher.

                       

                      So following msheraton's workaround I added an external task to copy a reduced Qlikmart on top of the existing file just before reloading.  This seems to be working fine, however I will raise the issue with Qliktech as well.

                       

                      Thanks msheraton for your post!!!  You saved my migration to QV11!!!

                      • Large file failing to reload

                        Try this:

                        I had similar problem in QV 10 SR3 with extract large data. I expand shared memory area in register.

                        I did:

                        1. run regedit

                        2. find SharedSection (edit--->find)

                        3. inside you have - ......SharedSection = 1024,20480,512)  --- (512 or more)

                        4. right click--->Modify

                        5. last value-512 (or what you have) multiply by 2   (512* 2 = 1024)

                        6. if needed multiplay by two again....or more,depending how much memory you have. We have 64GB of ram and I expand the last value to 12288 and now work fine.

                         

                        Worked for me.