18 Replies Latest reply: Sep 19, 2018 9:27 AM by Andrea Gigliotti RSS

    AccessPoint "Message: No Server"

      When using a browser to access AccessPoint (http://[hostname]/qlikview/index.htm), we receive a red banner "Message: No Server".  This message shows up when connecting to AccessPoint via the browser remotely or on the local server. 

       

      All servies are running according to QVMC and Windows Services. 

       

      We can connect to the QVS via the desktop QV client. 

       

      We are using IIS for the webserver. 

       

      The QV service account is in the QV and Local Admin groups.

       

      QVS version 11.0.11154.0

       

      I am fairly certain it is something really simple but after a number or reinstalls I am out of ideas.  Any help at all would be aprpeciated.

        • AccessPoint "Message: No Server"
          Miguel Angel Baeyens de Arce

          Hi,

           

          Does the QMC allows you to configure your web server? (QMC, System, Setup, QlikView Server) Is your server licensed? Check this post on how the config.xml file should look like.

           

          Hope that helps.

           

          Miguel

          • Re: AccessPoint "Message: No Server"
            Karthikeyan Subramaniam

            All,

             

            We do not have IIS_WPG group in our machine. Please let us know what to do with this situation.

              • Re: AccessPoint "Message: No Server"

                For those working on a similar issue as Karthikeyan:

                 

                I was able to do this with the group IIS_IUSRS.  After adding the account to the group and verifying the account was set as the ApplicationIdentityPool, I was able to load the Access Point.  Funny story though, I was using my personal account for the fix and it changed my permissions, kicked me out of the machine and didn't allow me to log back in until I reset my login permissions.  How rude!

              • Re: AccessPoint "Message: No Server"
                Grygoriy Terenin

                Hi,

                are you using SSL for the communication between the services?

                try to check all the settings.ini's and configs. I had the same problem and fixed it by correcting the web.config in %installPath%\Server\QlikViewClients\QlikViewAjax\

                 

                Also try posting the QV-/System Logs in this thread

                 

                Kind Regars,

                Gregor

                • Re: AccessPoint "Message: No Server"

                  Hi everyone,

                  In case you have installed Windows Server 2012, the No Server issue is resolved by installing the IIS Manager.

                  • Re: AccessPoint "Message: No Server"
                    David Logsdon

                    I had this same issue. The red banner tells you that the Application Pool is running in IIS, However, you might want to try and add the service account under the "Identity" in the advanced settings on the "QlikView IIS" pool as such "domain\serviceaccount". I hope this helps.

                    • Re: AccessPoint "Message: No Server"
                      Andrea Gigliotti

                      I got the below error and I fix it opening the port UDP 389 on firewall.

                       

                      below the webserver log with the error:

                      20180919T143318.758+0200 Information Load Settings from: C:\ProgramData\QlikTech\WebServer\config.xml

                      20180919T143318.820+0200 Error System.AggregateException: One or more errors occurred. ---> System.Exception: Authentication Failed ||    at QlikTech.NetClient.QvClient.Open() ||    at QVSWrapper.QlikViewServer..ctor(Action`2 i_Logger, String i_Hostname, Int32 i_Port, Mode i_Mode, Boolean i_Https) ||    at QlikView.AccessPoint.QlikviewServerSetting.Connect() ||    at QlikView.AccessPoint.QlikviewServerSetting.Try[T](Func`2 f, Func`1 fail, Boolean APLoadBal, Boolean useCache) ||    at QlikView.AccessPoint.QlikviewServerSetting.Ping() ||    at System.Threading.Tasks.Parallel.<>c__DisplayClass17_0`1.<ForWorker>b__1() ||    at System.Threading.Tasks.Task.InnerInvokeWithArg(Task childTask) ||    at System.Threading.Tasks.Task.<>c__DisplayClass176_0.<ExecuteSelfReplicating>b__0(Object ) ||    --- End of inner exception stack trace --- ||    at System.Threading.Tasks.Task.ThrowIfExceptional(Boolean includeTaskCanceledExceptions) ||    at System.Threading.Tasks.Task.Wait(Int32 millisecondsTimeout, CancellationToken cancellationToken) ||    at System.Threading.Tasks.Parallel.ForWorker[TLocal](Int32 fromInclusive, Int32 toExclusive, ParallelOptions parallelOptions, Action`1 body, Action`2 bodyWithState, Func`4 bodyWithLocal, Func`1 localInit, Action`1 localFinally) ||    at System.Threading.Tasks.Parallel.ForEachWorker[TSource,TLocal](IEnumerable`1 source, ParallelOptions parallelOptions, Action`1 body, Action`2 bodyWithState, Action`3 bodyWithStateAndIndex, Func`4 bodyWithStateAndLocal, Func`5 bodyWithEverything, Func`1 localInit, Action`1 localFinally) ||    at System.Threading.Tasks.Parallel.ForEach[TSource](IEnumerable`1 source, Action`1 body) ||    at QlikView.AccessPoint.QlikViewServerStatus.PingThread() || ---> (Inner Exception #0) System.Exception: Authentication Failed ||    at QlikTech.NetClient.QvClient.Open() ||    at QVSWrapper.QlikViewServer..ctor(Action`2 i_Logger, String i_Hostname, Int32 i_Port, Mode i_Mode, Boolean i_Https) ||    at QlikView.AccessPoint.QlikviewServerSetting.Connect() ||    at QlikView.AccessPoint.QlikviewServerSetting.Try[T](Func`2 f, Func`1 fail, Boolean APLoadBal, Boolean useCache) ||    at QlikView.AccessPoint.QlikviewServerSetting.Ping() ||    at System.Threading.Tasks.Parallel.<>c__DisplayClass17_0`1.<ForWorker>b__1() ||    at System.Threading.Tasks.Task.InnerInvokeWithArg(Task childTask) ||    at System.Threading.Tasks.Task.<>c__DisplayClass176_0.<ExecuteSelfReplicating>b__0(Object )<---

                       

                      I hope it can help.