7 Replies Latest reply: Jan 30, 2012 1:18 PM by anthonyb RSS

    Problematic Reloading

      Dear QlikCom,

       

      I'm having an issue with reloading. When I reload script on a document within the desktop client (10), it clears all of the data but does not return anything.

       

      We have a server license, and I'm using a config.xml file to connect to the database.

       

      Thank you thank you, for all help. Could not find any topics similar, and QlikView hasn't made an attempt to respond to my tickets.

        • Problematic Reloading
          Stefan Wühl

          It's quite hard to give any hint here, since your issue description is quite vague.

           

          Do you get any error messages while reloading?

           

          Do you have the same problem in the server or with other clients (Versions)?

           

          Have you enabled and checked the log file?

           

          Have you tried to debug your script (from script editor - Debug)?

           

          Could you post your script here?

            • Problematic Reloading

              Thank you very much for your quick reply swuehl.

               

              Opening the original document, the server data is definitely being displayed. When I reload, it shoots through very quickly without any errors and returns no tables. I've never had a successful reload. I'm working in QVW files that were made for our company by a consultant last year and I've taken over.

               

              On reload, all tables are removed from straight tables and charts. It doesn't even leave the column. Everything gets whiped.

               

              Please find script below. It's connecting to a config.xml file and communicating with our server.

               

              let InstallPath = getregistrystring('HKEY_LOCAL_MACHINE\SOFTWARE\Hard Dollar\HDAnalytics','InstallPath');

              if (len(InstallPath) = 0) then

              trace Registry key not found.;

              exit script;

              endif

               

              let ScriptPath = '';

              $(Include=$(InstallPath)\Scripts\Config.qvs);

              if (len(ScriptPath) = 0) then

              trace Config script not found.;

              exit script;

              endif

               

               

              $(Include=$(ScriptPath)\Config.qvs);

               

               

              $(Include=$(ScriptPath)\ResourceEmplCosts.qvs);

               

                • Problematic Reloading

                  When I ran the debugger, I got a return of "Registry key not found."

                    • Problematic Reloading
                      Stefan Wühl

                      If the registry key is not found, it will exit script execution, which would probably explain the quick execution and no data contained. Have you checked the registry key (exists, value)?

                        • Problematic Reloading

                          This may seem like a novice question but how could I go about troubleshooting that?

                            • Problematic Reloading
                              Stefan Wühl

                              Open the regedt32 utility and search for the key. Hm, if you are not familiar with registry keys, it might be better to ask someone to help you here. Depending on your rights, you may change some values which might affect your system.

                               

                              I think the registry value is just used to indicate the location of Config.qvs and maybe some other scripts.

                               

                              So, if you know the location, you just can state the location in your variable Installpath instead of calling the registry.

                               

                              Let InstallPath = 'c:\Temp';

                               

                              and remove or comment out

                              let InstallPath = getregistrystring('HKEY_LOCAL_MACHINE\SOFTWARE\Hard Dollar\HDAnalytics','InstallPath');

                               

                              Probably, c:\Temp is not your location ... Just an example