1 Reply Latest reply: Feb 13, 2012 8:32 AM by Isaiah Weed RSS

    QVS cluster configuration for PGO files

    Isaiah Weed

      We have a two-node QVS cluster.  AccessPoint (QV Web Server) is doing the clustering; e.g. there is no hardware load balancer "in front."

       

      Yesterday I implemented a nightly restart of the Qlikview Server service on both boxes in the cluster (I have found this to be a good practice in other environments.)  This morning I found that the allocation of leased User CAL's in the QEMC are gone; all of them.

       

      I'm guessing this could have something to do with the PGO files.  From the clustering white paper, I found this:

       

      Shared Network Storage

      This is required not only for the .pgo file mentioned above but also for storage of QlikView applications that are across the nodes in the cluster (.shared files).

       

       

      All of our QVW's are shared on network storage, but not the case with the PGO files.  Currently the PGO's are located on both QVS boxes, under C:\ProgramData\QlikTech\QlikViewServer.  The update timestamps on both sets (both boxes) matches, with the exception of BorrowedCalData.pgo,

       

      Does anyone know how the PGO location is properly configured for a clustered environment?

       

      Thanks -Isaiah

        • Re: QVS cluster configuration for PGO files
          Isaiah Weed

          Ok, I also see a copy of the PGO files (but no FUL.DAT) on the shared storage.  I'm guessing this is managed automatically.  Each set of the PGO's (server1, server2 and the shared storage) are getting updated rather regularly judging from the "last update" timestamps.

           

          So my real concern is, why after a restart of the Qlikview Server service on both boxes (done via NET STOP/START) would we lose the license lease allocation?  I did notice this from the EXIT.LOG file on both QVS boxes:

           

          2012-02-09 07:00:22: Termination not completed within 20s. Quitting!

           

          The qvs.exe process on both boxes was eating over 200GB of memory, so I'm not all that surprised that it wouldn't die gracefully within 20 seconds.  But could that be the problem with the license leases?

           

          Any insight is much appreciated.  -Isaiah