1 Reply Latest reply: Feb 28, 2012 3:40 AM by Stefan Bäckstrand RSS

    Upgrading to .NET Framework 4 with Qlikview 10

      Hello -

       

      I might just be overly cautious here, but I wanted to check and see if there are any expected problems with upgrading the .NET framework from 3.5 to 4.0.  I would like to do this while we are still running Qlikview Server 10 in preparation for updgrading to Qlikview Server 11. 

       

      Are there any known issues or any bumps which anyone has experienced when upgrading the .NET framework?

       

      Also, is it a best practice to stop the Qlikview service when upgrading the .NET framework, or can I simply download and install the upgrade while running Qlikview? 

       

      Thanks!!

        • Upgrading to .NET Framework 4 with Qlikview 10
          Stefan Bäckstrand

          By definition, you don't "upgrade" from .NET 3.5 to 4. You just add the .NET Framework 4.0 alongside with the other versions. So, it is farely risk free, yes.

           

          QlikView Server 11 have some components using 3.5, but does not require 4.0 unless for the components running under IIS, if that is used as web server for the QVS.

           

          A tip; make sure you have 4.0 installed prior to installing QlikView Server 11, especially before configuring IIS. That will save you some binding troubles in regards to ASP.NET and IIS.