This is very good.
However, in some cases the datasource field names are coded, i.e TLBKID, TRTTYP.
As a developer I would normally rename the fields on which I do something (where clauses, if statements etc.) in the beginning of the script, for better readability.
Then at the end of the script I could use your technique to rename the rest of the fields.