1 Reply Latest reply: Aug 14, 2012 10:13 AM by badboy81 RSS

    Append export macro not working in access point

      Hi,

            I am using macro to export the data from table object as excel sheet on selecting a one value field.

         

             sub expexc
             set ex1 = ActiveDocument.GetSheetObject("CH02")
             ex1.AppendExport "C:\ProgramData\QlikTech\QlikViewServer\expexc.xls" , ";"
             End sub

         

             1.Macro is working fine in the desktop and it is not working in Access point(IE Plugin).I enabled the system full access in macro module and enabled the unsafe macros in QMC.Still not working.

              2.Macro is exporting the excel but it is replacing the old file with new file whenever a new selction is made in the field.I am not a macro person.How to write the macro to export the data from the table to same excel file (keep adding the data to same excel file).

       

      Thanks in advance

       

        • Re: Append export macro not working in access point

          Hi,

          Have the same problem. It was working perfectly in QlikView 10, but since I upgraded to QlikView 11 SR1 it is not working anymore in the Webbrowser via IE-Plugin, it give me a error message, QlikOCX error, no functionality.

           

          Anybody some ideas how I can solve this issue or how I get the same result with another function?

           

          Thanks in advance.

           

          Kind regards,

          Herbert