5 Replies Latest reply: Apr 10, 2012 9:57 AM by Miguel Angel Baeyens de Arce RSS

    how to restrict users from accessing documents - Small Business Server

      Hi,

       

      Do you know where you can restrict users from accessing documents?

       

      I have checked on the server and tried various options without any joy?

       

      Does this have to be done in the script itself?

       

      We sre using Named CALS in Qlikview Server.

       

      Regards,

      GRegg

        • how to restrict users from accessing documents - Small Business Server
          Sunil Chauhan

          while creating a tak for reload

           

          a option for distribute application

          assign the name you want to access.

           

           

          and rest are automatically restricted .

           

           

           

          hope this help

          • how to restrict users from accessing documents - Small Business Server
            Miguel Angel Baeyens de Arce

            Hi Gregg,

             

            If you use Publiser, the suggestion by Sunil above will do. If you don't have a Publisher license, you will need to assign manually the permissions, either using the AD and NTFS permissions or in the Authorization tab in the QEMC/QMC > Documents menu. QlikView will use the OS permissions, so for example, there might be the case of one user with one Named CAL assigned, but with no permission on any file in the documents folder. Hence, the user will see no documents in the AccessPoint, even when he has a license properly assigned.

             

            Hope that helps.

             

            Miguel

              • Re: how to restrict users from accessing documents - Small Business Server

                Hi Miguel,

                 

                 

                 

                Thanks for that.

                 

                 

                 

                We do only have qlikview server – when I go to the QEMC/QMC and follow your instructions, I don’t see an option to restrict in documents menu.

                 

                 

                 

                I have chosen NTFS authorization (Windows controls file access) in QMC

                 

                 

                 

                I don’t know where exactly to input the users explicitly that can access the document.

                 

                 

                 

                Regards,

                 

                Gregg

                  • how to restrict users from accessing documents - Small Business Server
                    Miguel Angel Baeyens de Arce

                    Hi Gregg,

                     

                    The Small Business License only allows to use Windows Active Directory and NTFS permissions. Opposite is the DMS (Document Metadata Service), when QlikView controls who sees what based on a third party software (say Novell, Tivoli, NIS) or even by a Custom Directory, where you create users and passwords and groups within the Console itselft.

                     

                    This DMS authentication and authorization method is available in the Enterprise Edition of QlikView (if you don't which one do you have, contact your Partner Manager or your Sales rep), and the main difference in the Console is that in the Documents tab, when you expand your server and click on a document, a new "Authorization" tab appears and allows you to manually add users from any of the Directory Service Connectors as set up in the System tab, Setup, "Directory Service Connectors".

                     

                    To make sure which authorization method you are using go to the QEMC, System, Setup, QlikView Servers, Security and check the Authorization section. By the way, if you click on DMS, then click on the Apply button but the setting does not keep set, then you have the Small Business Edition license of QlikView Server.

                     

                    Hope that helps.

                     

                    Miguel