5 Replies Latest reply: Jul 12, 2012 12:31 PM by Giuseppe Masullo RSS

    QLIKVIEW 11 SBE - How can I avoid automatic login?

      Dear community,

       

      We have just installed Qlikview 11.0.11282.0 with a Small Business Edition server license.

      During the installation we decided to use Qlikview web server. We have a NT domain.

       

      Everything is working fine but I have a problem with user authentication.

      As soon as I connect to Qlikview access point, the server automatically recognize the client logged NT user and authenticate it without any sign-in screen.

       

      Usually this is a good feature, but it's not in our firm.

      For security reason, our internal security policy requires that any software containing personal data must require a specific authentication.

      This means that even if you have already been authenticated in the domain, you must re-insert your NT user name and password everytime you try to get access.

       

      I'm looking at all the available settings, but I haven't been able to make Qlikview ask for a login.

      I tried accessing QlikView Web Servers -> Authentication and set:

      - Authentication = Always

      - Login address = Alternate login page

       

      But nothing seems to change. Everytime I connect, the system let me access reports without any login screen.

       

      I'm sure I'm missing something.

      Do you have any idea on how to enable it?

       

      Thanks in advance

        • QLIKVIEW 11 SBE - How can I avoid automatic login?
          Pablo Labbe

          Have you tried to change your IE browser configuration to do not authenticate automatically on local intranet zone ?

           

          If you use Firefox or Chrome, they will always prompt for user credentials.

           

           

          Pablo Labbe

          Qlikview Consultant

          www.visiongi.com.br

          • QLIKVIEW 11 SBE - How can I avoid automatic login?
            Kaushik Solanki

            Hi,

             

               Try after changing this settings.

             

               Open IE and go to Tools -> Internet Options -> Security -> Custom Level -> Go to User Authentication and select Always Prompt for UserName and Password.

             

               Do this settings for Local Intranet.


               Hope this helps.

             

            Regards,

            Kaushik Solanki

              • QLIKVIEW 11 SBE - How can I avoid automatic login?
                Daniel Rozental

                If you're looking to do this on the server side you might consider using IIS as you'll probably have more control over security settings.

                 

                Remember to clear cookies before every attempt.

                  • Re: QLIKVIEW 11 SBE - How can I avoid automatic login?

                    Thanks you all for your answers,

                     

                    All of them have been really useful and at the end the problem is solved. Now the system asks for login and password. This is what I did:

                     

                    • Disabled automatic authentication on intranet
                    • Cleared cookies

                     

                    Thanks Daniel for your tip: I was not deleting cookies and this is why when I tested this procedure it was not working.

                     

                    Best regards
                    Fabio

                      • Re: QLIKVIEW 11 SBE - How can I avoid automatic login?
                        Giuseppe Masullo

                        We have the same problem after upgrading qlikview server to v 11.0.11282.0 using the same configuration (QVWS, Authentication = Always,type = NTLM, Login address = Alternate login page).

                        Using the same configuration in V10 everything work fine.

                        We noticed some different behavior between access point in v10 and access point in v11.


                        V11:

                        FIRST SCENARIO:  first attempt to login to AP after you open browser .

                        if you insert correct username and password in the forms and press submit you can  you can login in access point, if you insert wrong or empty password you will see the message "login failed".

                        If you  successfully login browser will cache your credential (if you set that browser have to do it).

                        If browser cache it you can login to access point simply pressing "submit. Example: if you press signout in access point you will return to login page....try to press submit after signing out....you will enter simply in AP without username and password....


                        SECOND SCENARIO: first attempt to login to AP after you open browser. If you try to press submit without an username or password  you will see a "popup" which request an authentication ,a web server authentication I think.

                         

                        V10: if you try   SECOND SCENARIO operation the web page will say "empty username" or "Login Failed" and you will not see any popup authentication.


                        May be this difference is due to different framework version between v10 and v11?

                        Is this a bug?