6 Replies Latest reply: Jun 14, 2012 4:35 AM by Snehal Bhosle RSS

    Qlikview SAP Connectivity Problem

      I am facing problems with respect to Qlikview’s connectivity with SAP. Please find the environment details below:

       

      Hardware Details:

      OS        :   Windows Server 2008 R2 sp1

      RAM    :   8 GB

      Disks    :   C:\ 50 GB, D:\ 100GB.

      SAP Details:

      SAP Version:           SAP ECC 6.0

      Basis:                      Release 701 Patch Level 3

      Qlikview Details:

      Qlikview version: 11 SR1

      QlikView version number :  11.0.11282.0

      Qlikview SAP Connector version: 5.5 SR3 (file ver. - 5.5.8698.0)

      SAP Transports file used: 640-700.zip (5.5 SR3)

       

      I have installed the SAP Connector as well as transports successfully (‘select * from t000’ statement is fetching records in SAP with the creates QTQVACCESS user). Moreover, when I test the SAP connection inside Qlikview it confirms that the test connection has succeeded.

       

      However, when I try executing the script builder it throws an error saying “Custom Read Failed”. I also tried using select statements on SAP tables – MAKT, t000 etc. but  getting the same error.

       

      I also tried using different versions of SAP connectors:

       

      •  5.6, 10755 SR2,

       

      •  5.6, 10640 - Initial Release

       

      •  5.5, SR2 but to no avail.

       

      I also checked on the dll version and it is same as the SAP connector version.