2 Replies Latest reply: Jun 15, 2012 9:42 AM by Nenad Vukovic RSS

    Applmap() does not bring correct results in some instances

      Hi all,

       

      I am familiar with the function but have encountered one strange issue with the ApplyMap function I like a lot. Suddenly it does not link correctly two exactly the same values in the mapping load and load fact for some lines. For example, if I check values created I get this:

      CodeFile

      "AB-1234" "Description 1234"

      "AC-4321" "Description 4321"

       

      Fact

      ApplyMap('CodeFile', 'AB-1234', '<Empty>') returns Description BUT ApplyMap('CodeFile', 'AC-4321', '<Empty>') returns <Empty>.

       

      I need to say that those CodeFiles and Facts are loaded into one QV table from the year dependent tables, i.e. CodeFile11 and CodeFile12 and Fact11 and Fact12. I tried to include Year into to key but then it didn't work at all. I've also tried to use text() and trim(text()) but no luck.


      I am still on the version 9 SR4.

       

      Thanks for ideas,

      Nenad