1 Reply Latest reply: Jun 25, 2012 8:45 PM by Michael Solomovich RSS

    Sql ansi problem in script

    Riccardo Cattermol

      Dear all

      i need your help!

       

      i have a simple  sql query  that return about 250.000 records if i run via  sqldeveloper. (oracle db )

      The same query return 16.000 record if i run via qlikview.

       

      I don't find the problem.

      The only peculiarity is the sql ansi sintax for join .. .

       

      See attached file for query detail .

       

      Best Regards and thank's for your help

      Riccardo

        • Re: Sql ansi problem in script
          Michael Solomovich

          Riccardo,

           

          If I had a chance to test it, I would do it by disabling lines in the WHERE clause, hence narrowing down the problem.  And, the lines I'd test first are these:

           

             and trunc(pll.last_update_date) between to_date('11/10/2011','dd/mm/yyyy') and sysdate+1 

             and tr.po_line_Location_id ( + ) = pll.line_location_id

             AND tr.transaction_type ( + ) = 'DELIVER'

           

          Because not sure how the bold items above work there.

           

          Regards,

          Michael