4 Replies Latest reply: Jul 3, 2012 10:12 PM by Johannes Sunden RSS

    How can I stop users from creating stupid objects?

    Brent Nichol

      I have had 2 instance where users have created server objects with containing all the fields.  They usually do this by creating a new Table Box and then pressing the 'Add All' button.  The result is usually an objects that takes 20-40 GB to load.  The server uses up all available memory, then starts swapping and eventually hangs.  At this pont the only countermesure is to stop and start the QlikView Server service.

       

      While I could just through more RAM at the problem, or do thorough testing of the 1000+ users, I would prefer to prevent this type of scenario.

       

      Can I limit the amout of RAM used by a user created collabortion object?

       

      My environment:

      QVS 9SR7 EE, Windows Server 2003 64bit, 32 GB RAM, 90+ Documents

       

       

      Any suggestions would be appreciated.

      B

        • Re: How can I stop users from creating stupid objects?
          Jakob Fabian

          Couldn't you just disallow the creation of server objects for in you QEMC?

          In QV 11 you can toggle this on the document and the server level - don't know if you have that option in QV9 SR7 - but I think you should have it if I remember it correctly.

           

          Best Regards,

          Jakob

            • Re: How can I stop users from creating stupid objects?
              Brent Nichol

              Sorry, I should have explicitly stated that I want to continue to allow users to create objects that would be beneficial to them and not detrimental to the server or any of the other users. 

               

              The server documents currently have over 2000 user created objects (excluding bookmarks) and turning off this functionality is not an option.

               

              Any thoughts?

               

              Regards,

              B

                • Re: How can I stop users from creating stupid objects?
                  Pablo Labbe

                  You could try to set the parameter "Object Calculation Time Limit" to a lower one. The default is 60 seconds but you can define it to 5 seconds or maybe less. Don´t define too lower because if you have complex document objects, they will  display the "calculation time exceded" error. Define a number of seconds that allows you to render the well designed objects , but also limit the bad ones to calculate and take all of the system memory.

                   

                  According to the manual "The Object Calculation Time Limit setting specifies the maximum amount of time the QlikView Server will attempt to calculate a chart object. The time is set in seconds of total CPU time. Note that

                  total CPU time is not same as elapsed real time on a computer with parallel processing technology".

                   

                  Best Regards,

                   

                  Pablo Labbe Ibaceta

                  Qlikview Consultant

                  Vision Gestão & Tecnologia

                  www.visiongi.com.br