5 Replies Latest reply: May 20, 2014 5:38 PM by Ivan Pinchera RSS

    Workbench connection issue.

    Igor Shchukin

      Hi everyone,

       

      I'm quite new to Qlikview.

       

      Could anyone please confrm that Workbench can be used remotely from Qlikview server(on another machine)?

       

      And if so, I'm trying to use DataSource object to connect to Qlikview server: I'm specifying QvsHost property of DataSource object, but having no luck with connection.

       

      The question is stupid, but could anyone please provide me with QvsHost naming pattern. Like for example, if you've got Qlikview server installed on SERVERNAME, then QvsHOST property should be equal to ...

       

      If it's any help, I can open the Access Point from my local machine. Do I need to open any ports for Workbench connection?

       

       

      Any help will be much appreaciated.

       

      Regards,

      Igo

        • Re: Workbench connection issue.
          John Coleman

          First thing to be sure of is that your license allows for workbench it would have a  line in the LEF for the server like:

           

          WORKBENCH;YES;;

           

          If you do not have this in the server LEF you cannot use workbench.

           

          By Remote I am assuming you have Visual Studio on your work station and QV server is on another machine.  This perfectly fine.   However you must have the proxy configured so that communication can occur.  When you did the install and you did the test did you get any errors?

           

          In the web config file you must have the following when the QVS is on another box.

           

          This is from my web config (see bold line):

           

          <QlikViewWorkBench>
             <General>
             <add key="Proxy" value="/Proxy.aspx"/>
             <add key="LogFile" value=""/>
             <add key="Header" value="QVUSER"/>
             <add key="QvAjaxZfcPath" value="http://servername/QvAjaxZfc/"/>
             </General>

            </QlikViewWorkBench>

           

          Severname = your QVS server.

           

          If you have workbench and QVs on the sam box then the line would look like this:

          <add key="QvAjaxZfcPath" value=""/>

           

          I would review the documentation and if you have trouble with the configuration I would contact your account manger and have some from Expert Services assist you.

            • Re: Workbench connection issue.
              Igor Shchukin

              Thank you very much for reply. Saved a lot of my time.

               

              Seem like we don't have the licence. Will try to sort it out.

               

              I was trying to follow the install manual that I found and actually was very suprised when I didn't get that proxy setup and test screen during the installation.

               

              Anyway thanks a lot for your help.

               

              Regards,

              Igor

              • Re: Workbench connection issue.
                Igor Shchukin

                Hi,


                Finally updated our licence.

                 

                Do I need to install WorkBench on the server? The problem is that I don't have Visual studio installed there and to be honest don't have a spare licence. Is it suppossed to work with Express version by any chance? Cause I seem to have troubles installing it.

                 

                Regards,

                Igor

              • Re: Workbench connection issue.
                Ivan Pinchera

                hello, i have a question in web config, how configuring when QVS has user and password??...