4 Replies Latest reply: Jul 12, 2012 4:14 PM by Calvin Francart RSS

    Partial data load from csv file on server, loads fully on laptop

    Calvin Francart

      This one has me completely stumped.

       

      I have a csv file with 223 records in it. I am doing a left join to an existing table, pulling just three columns out of the file. There is no WHERE clause in the load statement.

       

      When I run the refresh on the server, I'm only seeing 179 (this is according to the log file).

       

      There are other csv files with the same type of data in the same format being read in, and this is the only file I'm having any issue with.

       

      What I have been able to determine so far is that there is some commonality of the data that is not being read in. One column has 6 possible values; there are 29 rows that have a common value in that column which are missing, and there are another 15 with a common, but different, value as well.

       

      Now for the wierd part. I have local copies of the exact same files on my laptop. When I run it there, all 223 rows are being read in.

       

      Has anyone experienced anything like this before? If so, how did you correct it?