15 Replies Latest reply: Aug 29, 2012 12:45 PM by Bill Britt RSS

    New QV11 Test Servers doing my head in

      This is more of a {rant} at QlikTech than a question.

       

      I have over the past few months listened with great enthusiasm to Donald Farmer's various speeches about "QV.Next" and how it's going to be gorgeous and beautiful etc

       

      I then installed a QV11 test server at a client site.

       

      Unlike QV10, the words TEST in huge letters appear all over the shop, completely obsuring many of the objects within the applications. Amongst other things, this makes "TESTING" a complete nightmare... users can't see dimension attributes, have little or no idea half the time about what they are qliking on, and the whole appearance is pretty dreadful. Certainly not georgeous or beautiful!!

       

      C'mon guys - I know you have to differentiate between non-PROD and PROD environments and stop people taking the P#SS out of licensing rules, but surely in this day & age there is a better solution than obscuring pretty much everything with a big fat TEST.

       

      Or have I missed a switch or trick somewhere and this can be made more gorgeous?

       

       

       

      Regards,

       

      Will

        • Re: New QV11 Test Servers doing my head in
          Miguel Angel Baeyens de Arce

          Hello Will,

           

          The Test Edition license actually adds a watermark "Test" to the caption of the objects. Make sure you are running the most recent release of QlikView 11 (11282) and if that keeps happening or you already are running that version, I'd strongly recommend to contact your QlikView sales rep or partner manager if not support@qlik.com themselves so they can check if that's the expected behaviour or there might be any issues in the CSS or JS QlikView files (I haven't tested but I'd bet on the latter).

           

          As a side note and just to clarify, QV.Next is not QV11, but the version after 11.

           

          Hope that helps.

           

          Miguel

            • Re: New QV11 Test Servers doing my head in

              Hey Miguel :-)

               

              As a side note and just to clarify, QV.Next is not QV11, but the version after 11.

               

              I know - I was just commenting on this ugly bit of QV11

               

              So it should just add the Watermark to the object "caption"? - Interesting - on our deployment, this IS the case for listboxes, but for charts, the word TEST is emblazoned right across the chart and legend, making them pretty much unreadable in some circumstances... just wondered if there was a way to limit the watermark to just the object header in charts....

               

              Our version is 11282....

               

              Any other ideas? Thanks for chipping in...

               

              Will

                • Re: New QV11 Test Servers doing my head in
                  Miguel Angel Baeyens de Arce

                  Hi Will,

                   

                  Yes, that's the expected behavior, to add in both the captions and the backgrounds, as long as the data is visible... But I wouldn't bet against some mistakes on CSS styles / browser issues, specifically if you are using the Ajax client. I have not read about this issue in the QlikCommunity, but I guess is not very extended to use the Test Edition license of Server across the QlikCommunity members.

                   

                  For what it's worth, here you are what the Server Reference Manual says in regards to the test license. Bold is mine.

                   

                  QlikView Test Server comes in two editions, QlikView EE Test Server and QlikView SBE Test Server, both of which have the same features and limitations as the corresponding production servers. In addition, the watermark “Test” is superimposed on all charts and added to all object captions.

                   

                  I recall to have seen some pictures of the result in the Test server in some white paper or presentation, but I don't happen to find them.

                   

                  Hope that makes some sense.

                   

                  Miguel

                    • Re: New QV11 Test Servers doing my head in

                      Hmmm.. food for thought.

                       

                      It seems we are seeing "expected behaviour" then.

                       

                      Unfortunately, the client was not expecting (or particularly happy about) this visual intrusion having paid for a QV test licence. The client (and me) can't see why the visualisations should be impaired when we pay for a test licence, especially since this is not the case on pretty much ALL competing BI software (much of which is often FREE) that I have used...

                       

                      And also was not the case until they upgraded to QV11....

                       

                       

                        • Re: New QV11 Test Servers doing my head in
                          Miguel Angel Baeyens de Arce

                          Will,

                           

                          I understand what you mean. Unfortunately, I don't have a Test Licensed server to play with, so I cannot say if those watermarks seem normal or excessive to me, even in my personal point of view. Although the "Test" should appear in any case -because the idea is definitely differentiate a prod environment from a non prod environment, and this idea comes from a long ago-, as I mentioned do not hesitate to contact QlikView (Sales or rather Support) so they can check that particular client deployment.

                           

                          Are you experiencing the same with another version QlikView 11 test servers?

                           

                          Just out of curiosity I'm going to check this with my colleagues, just to see how the test server looks like in different environments, browsers and OSs.

                           

                          Best,

                           

                          Miguel

                  • Re: New QV11 Test Servers doing my head in
                    John Trigg

                    There was a bug introduced in V11 whereby the watermark became 'obnoxious'.  This is being fixed in SR2 (September), to return the watermark to a more true image as in V10. A patch is available from support if required

                    • Re: New QV11 Test Servers doing my head in

                      It definitely is more obtrusive now.  For example all my my Chart Names now just say @test server.  I am trying to figure out why it is not showing the titles with the @test server. 

                      • Re: New QV11 Test Servers doing my head in
                        Bill Britt

                        There might be some changes coming to this in a Service release. We will have to wait and see.