1 Reply Latest reply: Aug 1, 2012 8:20 AM by Ian Crosland RSS

    No Source Available - QVXServer.cs

    Mike Reese

      I am trying to create a QVX connector.  I'm not sure what is causing this error.  It doesn't fail on any specific line.  It says it can't find QVXServer.cs.  I've looked for the file and can't find it anywhere on the machine.  However, EventLogElaborate is running the same qvx code, but does not fail.  One difference is the eventlogelaborate app has the following files.  They are part of the solution, but not part of the project.  The icon is a blank page icon instead associated with these instead of a C# icon, presumably because they are not part of the project.  I'm not sure what's causing that:

      * QVXLibrary,dll

      * QVXLibrary,pdb

      * QVXLibrary,xml

       

      The 'using QlikView.Qvx.QvxLibrary' declaration is in both apps;

       

      The error possibly has something to do with the CreateLoginHelper routine.  As soon as the class is instantiated in my app, which does not show the files above, I get the following:

       

      No Source Available.

      The source code cannot be displayed

       

      Locating source for 'c:\b\QVXSDK-MAIN-BUILDQVXSDK\tfs\QVX SDK\Main\Source\QvxLibrary\QvxLibrary\QvxServer.cs'. Checksum: MD5 {bb 2f b2 e8 6f cb 59 e0 e4 5f c7 44 8e ac 1b 87}

      The file 'c:\b\QVXSDK-MAIN-BUILDQVXSDK\tfs\QVX SDK\Main\Source\QvxLibrary\QvxLibrary\QvxServer.cs' does not exist.

      Looking in script documents for 'c:\b\QVXSDK-MAIN-BUILDQVXSDK\tfs\QVX SDK\Main\Source\QvxLibrary\QvxLibrary\QvxServer.cs'...

      Looking in the projects for 'c:\b\QVXSDK-MAIN-BUILDQVXSDK\tfs\QVX SDK\Main\Source\QvxLibrary\QvxLibrary\QvxServer.cs'.

      The file was not found in a project.

      Looking in directory 'C:\Program Files\Microsoft Visual Studio 10.0\VC\crt\src\'...

      Looking in directory 'C:\Program Files\Microsoft Visual Studio 10.0\VC\atlmfc\src\mfc\'...

      Looking in directory 'C:\Program Files\Microsoft Visual Studio 10.0\VC\atlmfc\src\atl\'...

      Looking in directory 'C:\Program Files\Microsoft Visual Studio 10.0\VC\atlmfc\include\'...

      The debug source files settings for the active solution indicate that the debugger will not ask the user to find the file: c:\b\QVXSDK-MAIN-BUILDQVXSDK\tfs\QVX SDK\Main\Source\QvxLibrary\QvxLibrary\QvxServer.cs.

      The debugger could not locate the source file 'c:\b\QVXSDK-MAIN-BUILDQVXSDK\tfs\QVX SDK\Main\Source\QvxLibrary\QvxLibrary\QvxServer.cs'.

       

      I don't get why the file is missing from the machine for one app, but the other app with the same references has no errors running the same code.  I'm not a C# programmer so this all mostly new to me so any suggestions would be appreciated.  I'm sure I'm overlooking something basic.