5 Replies Latest reply: Aug 8, 2012 4:57 PM by Fernando Suzuki RSS

    Help on EDX Trigger

    Swapnil Joshi

      Hi,

       

      I am trying to triiger QlikView task externally.

      For that I am using "RequestEDX10.vbs" script found in this community.I have setup the task triiger to "On External Event"

       

      When I am executing the script from CMD I am getting below

       

      C:/cscript "C:\References\EDX\RequestEDX10.vbs" /t:"Arizona_Test" /p:<pwd>

       

       

      Microsoft (R) Windows Script Host Version 5.7
      Copyright (C) Microsoft Corporation. All rights reserved.

      =========================================================
      QDS URL:                [http://<Servername>/qemc/Default.htm]

      EDX Task:               [Arizona_Test]
      EDX Password:           [pwd]
                              -----------------------
      8/6/2012 3:38:50 PM     []

       

      Can somone please help me what does it mean? Is it a error or what?

       

      Thanks

      Swaps.

        • Re: Help on EDX Trigger
          Fernando Suzuki

          the message doesn't seem to show an error.

           

          are you using qv 10 or 11?

           

          can you post the link to the thread with the vbs script?

          • Re: Help on EDX Trigger
            Ben Thomas

            It's been a while since I tried that .vbs but just looking back at my testing notes, you should get something like

             

            8/6/2012 3:38:50 PM     [SUCCESS]        if it runs properly rather than just '[]' at the end. You'll also be able to see that the task is running (or ran recently) in the Management Console.

             

            Do you have publisher installed? If not then your task name is too short in your example and should look something like '{QVW Path}/{QVW Name}.qvw' . If you do have Publisher, I assume that you renamed your task from the default name that QlikView creates to 'Arizona_Test' (on V10 at least - not sure about 11). You should still get an error though if it can't find the task.

             

            From memory, that version of the .vbs file has to be edited to update it with the right QDS (QlikView Distribution Service) path, and QlikView EDX user credentials.  Have you checked that the user credentials in the .vbs belong to a member of the QlikView EDX group? You should get an error in any case if not so I'm not quite sure what's happening here.

             

            Let me know what steps you've taken to set this up in case I can spot something wrong.

             

            Regards,

             

            Ben

              • Re: Help on EDX Trigger
                Swapnil Joshi

                Thanks all for your reply.

                 

                @Ben, 1)I do have publisher installed

                          2)I think I have used the correct task name. Doest task name should have ".qvw" at the end?

                          3) I did not see job/task is running on the publisher box once execute the edx script.

                          4)Based on instructions I have edited the script with my QV server name and my uid and pwd.

                          5)Userid which I am using in the script is a part of QlikView administrator on server but not sure how to chk whether its part of QV EDW group. Also somewhere I read if uid is a part of QlikView adminitrator on server should work well.

                 

                I am trying this on QlikView 10.

                 

                I have tried executing this script from "cmd" promp on my system in same domain of server also on the publisher box "cmd" but getting the same response.

                 

                What do you think?

                  • Re: Help on EDX Trigger
                    Fernando Suzuki

                    Hi Swaps,

                     

                    The Login you're using to trigger the EDX must be added to the local server group 'QlikView Administrators' or 'QlikView EDX'.

                    I've used EDX in an environment without Publisher, and the task name was '[Mounted Folder]\[File name].qvw'.

                     

                     

                     

                    I'm not sure if you already know this, but the vbs you are using to trigger the EDX uses a method that no longer exists in v11. Cesar posted the link to the new method that was created in v10 and is the only possible in v11.

                • Re: Help on EDX Trigger
                  Cesar Accardi

                  Hi,

                   

                  I succesfully triggered EDX tasks using the command line tool in this post:

                   

                  http://community.qlik.com/docs/DOC-2650

                   

                  Regards,

                  Cesar