2 Replies Latest reply: Oct 2, 2012 5:15 AM by Matthias Schillinger RSS

    QV Macro runs only with loged in user?

    Matthias Schillinger

      Hello,

       

      I wrote a macro in qv to do an pdf export. The macro runs without any error when started while logged in. When I asked our IT to schedule it to run in the night, it stops the moment qv enters the macrocode.

       

      Our IT says that macros are only allowed with logged in users. Is there another way to get this problem solved?

       

      Regards,

       

      Matt

        • Re: QV Macro runs only with loged in user?
          Miguel Angel Baeyens de Arce

          Hello Matt,

           

          Based on what you describe, I'm assuming you are running the reload using a batch file instead of a Server task? If so, that's because you need to run the batch file as BATCH and not INTERACTIVE task in the Windows Scheduler. Check here for a very similar issue. The setting in the task is "Run whether the user is logged on or not". That's because the qv.exe opens a user dialog as when it is reloaded manually, and Windows understands that there is no user logged on, so the task fails.

           

          Hope that helps.

           

          Miguel

            • Re: QV Macro runs only with loged in user?
              Matthias Schillinger

              Hi Miguel,

               

              thanks for your reply. The linked threat you are refering to doesn't solve the issue. Because our IT is already using a user for the batchrun, that can start the batch file manually.

               

              More interesting is the setting u are refering to "Run whether the user is logged on or not". But I cant find this setting in our Taskplaner we just have a checkbox "Run only if user is logged in" (translated from German). But if we check this one the batch isnt running at all not even the first command which does the reload of the qvw.

               

              This part runs fine when the check isnt set.

               

              Regards,

               

              Matt