1 Reply Latest reply: Nov 26, 2012 10:57 AM by Gysbert Wassenaar RSS

    Empty fields not included

    Elisabetta Zunino

      Dear Qlikview community,

       

       

      I need help for this issue:

      I have a table downloaded from SAP.

      In this table the field date has several records empty.

      Qlikview show this field with the symbol "-".

      I would like to exlcude the empty fields.

      But I can't apply the filter because the system doesn't show me the option empty, but only the filled fields.

      How can I do that?

       

      Thanks

       

      Capture.PNG

        • Re: Empty fields not included
          Gysbert Wassenaar

          You can't select missing values in Qlikview. That's why you can't see missing values in the listbox. You could replace Nulls in the script using the NullValue variable. You can set this in the script with SET NullValue = 'Null';  (or some other string of your choice). There's also a NullAsValue function. See the help file for more info on how you can deal with Nulls.