7 Replies Latest reply: Dec 28, 2012 8:18 AM by David Vaanunu RSS

    Interface language popup crashes daily batch.

      Hello all,

       

      I have a daily scheduled process that runs with windows task scheduler.

      The process starts a batch script which runs the following command:

       

      qv.exe /r "Main Dashboard.qvw"

       

      This process usually works fine but once a week it crashes.

      When closing the qv error message and loading qv manually the problem is seems pretty obvius - a popup making me choose an interface language is showing up, preventing the qv.exe command to reload the qvw.

       

      Is there a way to prevent this popup to appear on a batch run? Why does it show up and isn't saved?

       

      Thanks in advanced,

      David.

       

      More details:

      Qv version: 11

      OS: Windows server 2008 R2 enterprise.

        • Re: Interface language popup crashes daily batch.
          Bill Britt

          This means something is deleting the Settings.ini file.

           

          Bill

            • Re: Interface language popup crashes daily batch.

              This might be a very good lead since i can't find settings.ini under C:\Program Files\QlikView.

              where should it be located?

               

              Edit:

              Ok. I did find it, but it is located on several location on the server. which one would be the relevant/active one?

              and why would it be deleted?

               

              Thanks,

              David

                • Re: Interface language popup crashes daily batch.
                  Bill Britt

                  It would be under the profile that the windows task scheduler is running under.

                   

                  Bill

                    • Re: Interface language popup crashes daily batch.

                      ok. now we are getting somewhere.

                      The relevant setting.ini is in:

                      "C:\Users\qsetadmin\AppData\Roaming\QlikTech\QlikView"

                       

                      This was the content when the popup apeared:

                       

                      [Settings 7]

                      InstalledLIBID110={15B258E8-415E-11D1-934D-0040333C91CC}

                      CanDynamicUpdate=1

                      MarginTop=20

                      LeasedLicenseExpiry=2013-01-26 17:40:01, 2012-12-27 17:40:01

                      LeasedLicenseServer=qvp://bi1-p

                      LeasedLicenseCheck=6ed17d6a61ac4b7a768c8d00d81ad23ffa699fbadfb34a82446889780e213741

                      CurrentQVConnect64Loc=

                      [Recent File List]

                      File1=F:\BI\QlikView_Books\server_root\Billing.qvw

                      File2=F:\BI\QlikView_Apps\DASHBOARDS\books\Main Dashboard.qvw

                      File3=F:\BI\QlikView_Apps\DASHBOARDS\get_agg_data2.qvw

                      File4=F:\BI\QlikView_Apps\DASHBOARDS\get_last_date.qvw

                      [WindowPos]

                      DlgPos235=1117,276,529,459,0

                       

                      This was the content after i've set the language to be english:

                       

                      [Settings 7]

                      InstalledLIBID110={15B258E8-415E-11D1-934D-0040333C91CC}

                      CanDynamicUpdate=1

                      MarginTop=20

                      LeasedLicenseExpiry=2013-01-27 06:51:12, 2012-12-28 06:51:12

                      LeasedLicenseServer=qvp://bi1-p

                      LeasedLicenseCheck=304ee50f1d10b8c69e59d397cd1109c0dc0fc984fbc5d8ebf410e6165e88d827

                      CurrentQVConnect64Loc=

                      InterfaceLanguage=English

                      HelpLanguage=

                      [Recent File List]

                      File1=F:\BI\QlikView_Books\server_root\Billing.qvw

                      File2=F:\BI\QlikView_Apps\DASHBOARDS\books\Main Dashboard.qvw

                      File3=F:\BI\QlikView_Apps\DASHBOARDS\get_agg_data2.qvw

                      File4=F:\BI\QlikView_Apps\DASHBOARDS\get_last_date.qvw

                      [WindowPos]

                      DlgPos235=1117,276,529,459,0

                       

                      I'm think it's got somthing to do with the profile being a "roaming profile".

                      can that be the issue here? what else can cause this?

                       

                      Thanks,

                      David.