1 Reply Latest reply: Feb 11, 2013 7:00 AM by Syed Shah RSS

    URL redirect to report works in FF, but not in IE and chrome

    Syed Shah

      Hi All,

       

      My customer wants the users to be redirected directly to a report instead of accesspoint. I have put the document URL in the http redirect of IIS. So basically when someone visits the default domain, they are redirected to the document.

       

      In IIS7.5 http redirect, I have put the document URL in the redirect requests to this destination. I have selected "only redirect requests to the contents in this directory".

       

      Now the problem is that when I visit the links in FF, the reports opens successfully. However, If I try in IE or chrome, I get a No Connection error

       

      Can someone please suggest what could be wrong with the way I have redirected the URL. If I disable the redirection and put the document URL directly in the IE address bar, it works perfectly. However, it does not work with http redirect method

       

      Regards

      Arif

        • Re: URL redirect to report works in FF, but not in IE and chrome
          Syed Shah

          I just found that internet explorer adds a traling slash (/) to the end of URL which is causing a problem. If I manually remove this slash, the link works fine.

           

          How can I make IE and chrome not to put the ending slash to the URL. for some reasons, FF is not doing so and that is why it correctly opensup the report. chrome and IE both add the ending slash to URL which basically cause the broswer to look for a directoy rather than a file

           

          If I can somehow fix this, the report will also get fixed

           

          Syed