4 Replies Latest reply: Mar 12, 2013 4:47 PM by Matias Panasci RSS

    Error: Tabla no encontrada

      Resulta que estoy haciendo una extraccion de datos de un SAP. Tengo un script que cada vez que se ejecuta via agenda de qlikview server falla. Si este mismo script es ejecutado en modo depuracion funciona perfectamente.

       

      Alguien sabe cual puede llegar a ser el motivo ? el error que queda en el log es el siguiente:

       

      12/03/2013  1:59:48 PM: 0136  FOR i=0 TO 0

      12/03/2013  1:59:48 PM: 0138    tFilter:

      12/03/2013  1:59:48 PM: 0139        LOAD concat(OBJECTID, ',') AS vFilter

      12/03/2013  1:59:48 PM: 0140        RESIDENT Modificaciones

      12/03/2013  1:59:48 PM: 0141        WHERE 0*500 < RecNo() AND RecNo() <= (0+1)*500

      12/03/2013  1:59:48 PM:             1 fields found: vFilter, 0 lines fetched

      12/03/2013  1:59:48 PM: 0143    LET vFilter = peek('vFilter')

      12/03/2013  1:59:48 PM: 0145    DROP TABLE tFilter

      12/03/2013  1:59:48 PM: 0147    IF ''<>'' THEN

      12/03/2013  1:59:48 PM: 0160  NEXT

      12/03/2013  1:59:48 PM: 0163  CONCATENATE (EKKO)

      12/03/2013  1:59:48 PM: 0164  LOAD *

      12/03/2013  1:59:48 PM: 0165  WHERE NOT exists(EBELN)

      12/03/2013  1:59:48 PM:       Error: Table not found

      12/03/2013  1:59:48 PM:       General Script Error

      12/03/2013  1:59:48 PM:       Execution Failed

      12/03/2013  1:59:48 PM:      Execution finished.

        • Re: Error: Tabla no encontrada

          Para descartar el problema,

           

          1. ¿Has intentado cargar una sola tabla en vez del bucle desde el servidor?
          2. ¿La cadena de conexión es correcta desde el servidor?
          3. Cuando ejecutas en modo depuración, lo realizas en el mismo equipo/servidor o en uno distinto.

           

          Saludos,

          Ricardo

            • Re: Error: Tabla no encontrada

              Gracias por responder Ricardo, te contesto las preguntas:

               

              1- Si he intentado cargar una sola tabla y funciona.

               

              2- La cadena de conexion es correcta el script es mucho mas largo y las otras tablas del script funcionan correctamente. De echo la tabla que falla lo hace segun como se corra el script.

               

              3- Probe 4 modos de ejecucion:

               

              a) Paso a paso (Depuracion con carga limitada).

              b) Paso a paso (Depuracion).

              c) Desde el archivo QVW.

              d) Desde la agenda del server.


              En todos los casos se corrio el mismo archivo en la misma pc. En el unico momento que falla es cuando el script es ejecutado desde la agenda, eso es lo desconcertante.

                • Re: Error: Tabla no encontrada

                  Hola,

                   

                  Investiguemos un poco mas:

                   

                  Por la respuesta que me das para la primera pregunta,

                   

                  ¿Has intentado cargar una sola tabla en vez del bucle desde el servidor?

                  Si he intentado cargar una sola tabla y funciona

                   

                  ¿Esta carga de una sola tabla lo hiciste desde la agenda o en modo depuración?

                   

                  Respondeme

                   

                    • Re: Error: Tabla no encontrada

                      ¿Esta carga de una sola tabla lo hiciste desde la agenda o en modo depuración?

                       

                      De las 2 formas, he extraido una tabla entera usando la misma conexion desde un QVW y tambien lo he realizado desde la agenda.

                       

                      Tengo la cadena de conexion en un archivo de texto y lo importo en todos los scripts, son mas de 20 scripts y todos funcionan bien, salvo por este. Ademas los scripts estan todos encadenados uno detras de otro para evitar solapamientos.