1 Reply Latest reply: Sep 24, 2013 3:32 PM by Philippe Grenier RSS

    Bug when loading CSV file with quotes

      Hi,

       

      I am loading up a flat file which has product names in. Some of these names have comas inside the description so the products have been wrapped in " (double quotes).

       

      However any subsequent file is not loading. I believe that the script is not intepreting the code properly as there is only a single " (double quote) in the code.

      .
      .
      .
      FROM
      [..\myproduct.csv]
      (txt, codepage is 1252, embedded labels, comment is ", delimiter is ' ', msq);
      
      

       

       

      anything after this seems to be intepreted as being inside quotes and no files after this load. i've tried various things to sort it out, but i guess it looks like i'll have to change the source data so that the quotes are removed and that the delimiter is different.

       

      cheers

        • Re: Bug when loading CSV file with quotes
          Philippe Grenier

          Hello,

           

          I believe the source of the problem resides in the comment parameter: There should be 2 " characters rather than only one.

           

          LOAD *

          FROM  [..\myproduct.csv] 

          (txt, codepage is 1252, embedded labels, comment is "", delimiter is ' ', msq);


          If you wish, you may also omit that parameter:


          LOAD *

          FROM  [..\myproduct.csv] 

          (txt, codepage is 1252, embedded labels, delimiter is ' ', msq);


          Regards,


          Philippe