5 Replies Latest reply: May 22, 2013 1:32 AM by s j RSS

    SAP Connector Versions

    Paul Ferguson

      Hi All,

       

      I'm hoping someone can enlighten me as I appear to be in the dark at the moment and need some support.

       

      We have been working to try and get the sap connector working for 2 weeks now with bapis however I think we have 1 of 2 issues.

      Firstly does anyone know why we get and error message when trying to use the 5.70 connector and it wouldnt work? we have to use the 5.50 to successfully connect to the system however this doesnt have the BAPI functionality we are looking for.

       

      The base system is 6.40 and we have the transports instlled correctly for this i believe this is matched to 5.50 of the connector?

      Do we need to upgrade to version 7.00 of sap to be able to use the 5.70 connector with this or should we be able to use the connector regardless to the model as long as it has the correct transports?

       

      The second may be that we need to use the 5.50 connector, does anyone have a conclusive direction to go with this connector to allow us to use bapis in sap?

       

       

      Many Thanks Paul

        • Re: SAP Connector Versions
          Frank Siciliani

          The transports version have to match the connector. If you are trying to use 5.70, then you need to load the transports that go with it.

           

          Frank

            • Re: SAP Connector Versions
              Paul Ferguson

              Hi Frank,

              Thanks for the response, so just to check what you have said for my own sanity, if the base system of SAP is 6.40 we can only use the 5.50 SAP sap connector?

               

              In essence would this mean that we would have to upgrade SAP to the 7.00 version to be able to use the 5.70 connector with BAPIS?

               

              Apologies im new to the world of SAP

              Many Thanks

              Paul

                • Re: SAP Connector Versions
                  Frank Siciliani

                  Paul,

                   

                  You should be able to use the 5.7 connector, but you must install the transports that match. If you are mixing the transports from 5.5 and trying to use 5.7, you will run into issues.

                   

                  Frank

                    • Re: SAP Connector Versions

                      Hi Paul,

                       

                      Just two comments to follow Frank's.  You may want to check the dates of your SAP transports.  There is a newer version of 5.7 - it's 5.7 SR1.  The original transports are dated July 2012, and the newer ones are dated October 2012.  The older one can cause errors. 

                       

                      Also, you need to uninstall version 5.5 of the executable on your QlikView server and install version 5.7.   The executable name is QlikViewSAP_x64Setup.exe, dated November, 2012.

                       

                      Jackie

                • Re: SAP Connector Versions
                  s j

                  You do not need to upgrade SAP Basis version from 6.40 to 7.00 to use SAP Qlikview connector.

                  because SAP Connector have different transport file for each  SAP version. I will suggest you to use tranport file according to Qlikview connector version and SAP Basis version.