1 Reply Latest reply: Jun 7, 2013 9:15 AM by Friedrich Hofmann RSS

    Triggers in QlikView - passing info from one doc to another

    Friedrich Hofmann

      Hi,

       

      I tried, together with a consultant, to implement links from app_A to app_B, together with a piece_of_info passed from the one to the other so that app_B will automatically open a specific sheet. The passing of the info worked okay using an extra table with the sheet_IDs of every app to be included in the scheme - but the triggers in QlikView just did not work the way we expected them to.

      - Setting a variable depending on the transferred selection worked fine.

      - Opening a worksheet depending on that variable worked fine.

      - Opening a worksheet depending on a selection worked fine.

      <-> Taken together, they just did not work, even when we tried using triggers on different levels (document/ worksheets/ selections/ variables).

      We made it with a macro in the end, but that is not the way it should be. Has any of you experienced and maybe solved that issue?

      Then there also were several weird behaviours of the triggers like, one button should open a document (doc_name depending on a variable), then clear all selections and then close. What it did was, it opened the correct document - and closed it again right away instead of closing itself...

      Best regards,

       

      DataNibbler

        • Re: Triggers in QlikView - passing info from one doc to another
          Friedrich Hofmann

          Hi,

           

          now there is a new problem:

           

          The macro that we have devised to automatically open the right sheet when opening the app via doc_chaining seems to be blocking any other triggers the colleague who created that app has actually implemented: When that sheet is activated, there should be an automatic selection in one field - on some sheets, there are automatic selections in several fields - that is not happening when that sheet is opened by the macro.

          When I open another sheet in that document and then revert, the selection is triggered all right - so the trigger in itself works as expected. It is just the combination of different functions that does not.

           

          Has anyone experienced such an issue before?

           

          Thanks a lot!

          Best regards,

           

          DataNibbler