1 Reply Latest reply: Jul 10, 2013 6:14 AM by Jonathan Brough RSS

    Reloadengine disconnected - Malformed Notification.xml and LoadBalance.xml

    Jonathan Brough

      When I log onto the QMC I get a red cross icon telling me that the Reloadengine is disconnected, with a message in the bottom right hand pane saying 'Failed to contact service'.

       

       

      I have restarted the server and all 5 services are running: Directory Services, Distribution Service, Server, Management Console and Web server

      Services are run under an account that is a member of the Administrators and the QlikViewAdministrators groups.

       

      EventViewer reports failures to run reload tasks, after these other events are shown (includes the service's name):

      QlikView Distribution Service: Service started

      QlikView Distribution Service v10.0.9282: Failed to read from C:\ProgramData\QlikTech\DistributionService\LoadBalancer.xml.

      QlikView Distribution Service v10.0.9282: Failed to read from C:\ProgramData\QlikTech\DistributionService\Notification.xml.

      QlikView Distribution Service v10.0.9282: Initializing Runtime environment. Currently Logged On User=clickview\admin

      QlikView Distribution Service v10.0.9282: Initializing QlikView Distribution Service... Please wait..

      QlikViewWebServer: Service started

      Qlikview Management Service: Service started

      QlikView Directory Service Connector: Service started

       

      I think the 'QlikView Distribution Service' starts (and can be seen running in the Services), but QMC reports on the 'QlikView Distribution Service v10.0.9282' service which seems to have problems getting going. The two expected xml files exist and I have given the QlikView Administrators group access to read them (it did previously give Adminitrators access).

       

      Log files taken from the C:\ProgramData\QlikTech\Distribution Services\1\Logs directory are also attached. I have truncated the July 4th and 5th Cluster logs (using ....... lines) as they were looping on a request for the Notification.xml and LoadBalance.xml files, resulting in 70Mb plus files. Maybe a process fired off on the 4th and stopped on the 6th July. Each of these loops ended with lines 'Deleting malformatted file', though the files look the same as one my development machine.

       

      Some details taken from the About QlikView page on the QMC:

      - Client Build Number: 10.0.9282.8

      - Operating System Version: Win32_OperatingSystem=@ X64 (Microsoft Windows NT 6.1.7601 Service Pack 1)

      - .NET Version: 2.0.50727.5466

      - No Publisher License

       

      Any advice would be much appreciated.

      Jonathan