5 Replies Latest reply: Jul 12, 2013 10:47 AM by matspike RSS

    Is my replace expression working or not?

      Hi, i'm new to qlikview and testing some things out with the demo version of qlikview. We will be purchasing the real version next year so i wanted to get a headstart as i will be in charge of implementing qlikview for our company. The idea is that the dimension 'UK' is replaced with 'EU'(this works) and that blank dimensions are replaced with the value '_NVT'.(this seems to work only partly)

      So i have tried the following script lines to clean up some of our data. But none of them seem to work, or are they?

       

      replace(replace("Gen_ Bus_ Posting Group", null(),'_NVT') ,'UK','EU') as "Global Dimension",

       

      replace(if(isnull("Gen_ Bus_ Posting Group")=0, "Gen_ Bus_ Posting Group", 'BINNENL') ,'UK','EU') as "Global Dimension",

       

      replace(if(len("Gen_ Bus_ Posting Group")=0,'_NVT') ,'UK','EU') as  "Global Dimension",

       

      I have also tried repalce isnull() with ' ' and 0 but i have been unable to fix it still.

      I cannot share the qlikview file as it includes a lot of our companies' sensitive information.

      The end result can be observed in the attached printscreen.

      I am unable to select the brown part of the graph and by filtering i can actually see that there are no longer any values containing blank dimensions. So im guessing it sort of works, but why is my graph going wrong? and is there something i can do about it, preferably id not have the empty dimension display at all, so how would i go about doing that?