1 Reply Latest reply: Feb 20, 2014 5:47 PM by Michael Steedle RSS

    PROBLEM COMMENT TABLES AND FIELDS

      Hi,

       

       

      I have a problem to comment my tables and fields. My comments are in 2 XLS files. Here is my code :

       

      TABLES:

      MAPPING LOAD TABLE as TableName,

           DESCRIPTION as Comment

      FROM

      [TABLES.xls]

      (biff,embedded labels);

       

       

      CHAMPS:

      MAPPING LOAD CHAMP as FieldName,

           DESCRIPTION as Comment

      FROM

      [TABLES ET CHAMPS.xls]

      (biff,embedded labels);

       

      comment tables using TABLES;

      comment fields using CHAMPS;

       

       

      I don't know why, it's working fine with some tables and some fields, and it doesn't work for some others. I don't see any differences between the tables working, and the tables not working.

       

      Any idea ?

       

      Thanks a lot.

        • Re: PROBLEM COMMENT TABLES AND FIELDS
          Michael Steedle

          I have seen the same and can find no pattern to which comments appear and which don't, but it seems to be a problem that is limited to the Table Viewer only. The comments are being accepted in the data model. You can verify this by reading in the XML header of the QVW with the data model you have commented. For example:

           

          TableDescription:

          LOAD Name as TableName,

              Comment as TableComment

          FROM [<your QVW name>.qvw] (XmlSimple, Table is [DocumentSummary/TableDescription]);