3 Replies Latest reply: Oct 21, 2015 9:24 AM by Martin Mahler RSS

    Sharepoint Webparts not listing documents

    Martin Mahler

      Hi everyone,

       

      I am currently trying to deploy QV WebParts on a test environment and I am facing some difficulties with the implementation.

       

      My current scenario:

      VMware virtual machine 1: QV Server 11.20 SR3 on Windows 7

      VMware virtual machine 2: SharePoint Server 2010 and QV Webparts (for 11.20 SR3 build) on Windows Server 2008

       

      I managed to install QV Webparts with a Proxy (because QV Server and Sharepoint are on different servers) on 2 and it's showing up as a Webpart in SharePoint, however NO documents are listed in the QlikView Object Selector:

       

      webpartsnodocuments.jpg.png

       

      The following settings are set/this is what I have tried:

      - The QvAJAXZfc Path is correct and Proxy is set according to the installation manual and is listed on web.config.

      - Authentication on QV server is set to Anonymous to avoid 'double hop' issues.

      - FireWalls are turned OFF on both servers (for testing purposes).

      - AccessPoint can be accessed by the machine 2 Webbrowser.

      - Documents are viewable on Accesspoint for Anonymous and access is authorized for "All Users" on QMC

      - I can even implement AccessPoint within a Page Viewer Webpart in SharePoint.

      - Security settings, blocked file endings etc. are all set to OFF on SharePoint

      - There are enough CAL sessions available.

      - WebParts;YES is listed in the LEF.txt so the license for WebParts is available.

      - There are no entries made in the Events or Sessions logs of QV the server while trying to add the Webparts object.

      - I have NOT tried using a Kerberos authentication, because in my view at this point it's not necessary when I don't need an authentication on the QlikView server (set to anonymous).


      As you can see, I am a little bit stuck and I would appreciate help or ideas from anyone who has experience with this subject.

       

      Thanks a lot,

      Martin