10 Replies Latest reply: Oct 25, 2013 4:31 AM by Bill Markham RSS

    Qvw running slow on faster server

      Hi,

       

      I have qvw that runs on a large amount of data. I have hosted the Qlikview enterprise server on to 2 separate machines. One is UAT and one is Prod. The UAT server has 10 GB RAM. On the Prod server I have 32 GB RAM. Both the servers have same processors (8 core) and are wintel severs. However the performance on the UAT server is much better than on the Prod server. Whenever I run a filter it's visibly slow on the server with the higher specs.

       

      I have tried doing a lot of things. Yet the speed is slow for the exact same file with the exact same data on the server with higher hardware configuration. Can someone please help?

       

      Thanks.

        • Re: Qvw running slow on faster server
          Jason Michaelides

          What are the other differences between Prod and UAT? Are the QVS builds the same? Cold load on Prod be to blame?

           

          Jason

            • Re: Qvw running slow on faster server

              Hi Jason,

               

              Hardware wise the main difference is only that Prod has higher spec. Can you please elaborate what do you mean by the QVS build and how can I check it?

               

              Loading is also the same. I tried copying the qvw loaded in UAT into Prod server and even then performance is slow.

               

              A bit more on the server

               

              Prod Specs

              OS: Windows 2008 R2 Service Pack1

              CPU: 8 Core 2.4 Ghz Six-Core AMD Opteron 8431

              Memory: 32768 MB - All available to Qlikview server

              Model: VMware, Inc. Virtual platform

               

              UAT Specs

              OS: Windows 2008 Service Pack 2

              CPU: 8 Core 2.4 Ghz Quar-core AMD Opteron 2378

              Memory: 32765 MB - 10Gb reserved for Qlikview Server

              Model: HP Proliant BL465c G5

                • Re: Qvw running slow on faster server
                  Jason Michaelides

                  QvS = QlikView Server. Are both environment running exactly the same software version. What is that version? And is there already a significant load on Prod?

                    • Re: Qvw running slow on faster server

                      I also got the following:

                       

                      Prod:

                       

                      Operating System Windows Server 2008 R2 Enterprise Service Pack 1 (64 bit edition)

                      Operating System Version 6.1.7601

                      Wow64 mode Not using Wow64

                      QlikTech Product QlikViewServer 64-bit Edition (x64)

                      Product Version 11.20.11718.0

                      CPU Target x64

                      Country 1 United States United States

                      Language 0409 English (United States) English

                      Server Collaboration Enabled

                      Number of CPUs 8

                      CPU 0  Six-Core AMD Opteron(tm) Processor 8431 2415MHz

                      CPU 1  Six-Core AMD Opteron(tm) Processor 8431 2402MHz

                      CPU 2  Six-Core AMD Opteron(tm) Processor 8431 2400MHz

                      CPU 3  Six-Core AMD Opteron(tm) Processor 8431 2402MHz

                      CPU 4  Six-Core AMD Opteron(tm) Processor 8431 2402MHz

                      CPU 5  Six-Core AMD Opteron(tm) Processor 8431 2402MHz

                      CPU 6  Six-Core AMD Opteron(tm) Processor 8431 2402MHz

                      CPU 7  Six-Core AMD Opteron(tm) Processor 8431 2402MHz

                      Physical RAM(MB) 32767

                      VMCommitted(MB) 2251

                      VMAllocated(MB) 2489

                      VMFree(MB) 28012

                      VMLargestFreeBlock(MB) 28012

                       

                       

                      UAT

                       

                      Operating System Windows Server (R) 2008 Standard Service Pack 2 (64 bit edition)

                      Operating System Version 6.0.6002

                      Wow64 mode Not using Wow64

                      QlikTech Product QlikViewServer 64-bit Edition (x64)

                      Product Version 11.20.11718.0

                      CPU Target x64

                      Country 1 United States United States

                      Language 0409 English (United States) English

                      Server Collaboration Enabled

                      Number of CPUs 8

                      CPU 0  Quad-Core AMD Opteron(tm) Processor 2378 2400MHz

                        CPU 1  Quad-Core AMD Opteron(tm) Processor 2378 2400MHz

                        CPU 2  Quad-Core AMD Opteron(tm) Processor 2378 2400MHz

                        CPU 3  Quad-Core AMD Opteron(tm) Processor 2378 2400MHz

                        CPU 4  Quad-Core AMD Opteron(tm) Processor 2378 2400MHz

                        CPU 5  Quad-Core AMD Opteron(tm) Processor 2378 2400MHz

                        CPU 6  Quad-Core AMD Opteron(tm) Processor 2378 2400MHz

                        CPU 7  Quad-Core AMD Opteron(tm) Processor 2378 2400MHz

                        Physical RAM(MB) 32764

                        VMCommitted(MB) 9801

                        VMAllocated(MB) 10218

                        VMFree(MB) 18602

                        VMLargestFreeBlock(MB) 18602

                    • Re: Qvw running slow on faster server
                      Jason Michaelides

                      One obvious difference is that PROD is a VM whereas UAT is a physical server. Generally, QV performs better on physical machines.

                       

                      Do you have any other production applications? Have you tried running them on UAT to see if the issue is isolated to the specific qvw?

                        • Re: Re: Qvw running slow on faster server
                          Bill Markham

                          Hi

                           

                          I'd agree with Jason that the PROD being a VM is likely to be the joker in the pack.

                           

                          When you say the PROD VM has:

                          Memory: 32765 MB - 10Gb reserved for Qlikview Server


                          That does not mean that it has 10Gb of physical RAM, it means it has 10Gb of virtual RAM and could well be thrashing.  Plus it may well also be CPU Thrashing.


                          Without looking at your VMware config & set up it is impossible to give any definitive conclusion.


                          I'd suggest you have 2 main options :


                               Either:     Look at the VMware stats, see if it is thrashing & if so stop it thrashing


                               Or:          Bite the bullet, get your wallet out and buy a physical PROD box



                          Best Regards,     Bill


                    • Re: Qvw running slow on faster server
                      Tresesco B

                      It could be because of improper memory management. Possibly, this has got nothing to do with QV but with the server hardwae configuration and settings. You might want to have a look at links like : Does adding more RAM to your computer make it faster? And, Computer slower after adding more Ram - Computing.Net

                       

                      Aprt from these, there could be issues like : 'Improper Paging Settings'; 'Virtual System'

                      • Re: Qvw running slow on faster server

                        Intel Chips are recommended rather than AMD chipsets.  You will gain significant performance benefits using Intel compared with AMD.

                         

                        You will find that more or bigger doesn't always translate to faster QV performance. For wide data its better to use more, lower specific cores (more cycles) that few fast cores. Whereas, with narrow data (deep but narrow) less higher specification (higher Ghz) cores give greater performance. I would check the hardware optimisation settings in the Bios also.

                         

                        Thanks Steve

                        • Re: Qvw running slow on faster server
                          Paul Scotchford

                          As stated above, I would also recommend getting your prod server (for QV) onto a Physical box, we run Dev / UAT on a VM, but the prod server is a Physical Intel box (large mem and many cpu's)