Skip to main content
Announcements
Qlik Introduces a New Era of Visualization! READ ALL ABOUT IT
cancel
Showing results for 
Search instead for 
Did you mean: 
Aurelien_Martinez
Partner - Specialist II
Partner - Specialist II

Big Shapefile with Qlik GeoAnalytics

Hi,

When I want to load a (big) shapefile with Qlik GeoAnalytics Plus, I have this error :

QVX_SYNTAX_ERROR: *GeoAnalytics Plus has memory problem, please increase the memory in the geoAnalyticMemory setting in the config file

I have found the config file, and tried this :

<add key="geoAnalyticMemory" value="9999999999999999999999999999"/>

but that did not worked ;(

PS : it is working with a small file

PS : I have QlikView 11.20 SR15

Aurélien

Help users find answers! Don't forget to mark a solution that worked for you!
1 Solution

Accepted Solutions
Ana_Yakushi
Employee
Employee

Hi Aurélien,

Could you please confirm that you are using Qlikview and changing the memory parameter in this file:

C:\Program Files\Common Files\QlikTech\Custom Data\QvIdevioConnector\IdevioGeoAnalyticsConnector.exe.config

I tried with one of your shapefiles (the biggest one with 128Mb) and a 4000Mb memory setup worked fine for me.

Just as a comment, the files conforming your shapefile (.shp, .prj, etc) have to be zipped in a .zip file (not .7z).

Best Regards,

Ana

View solution in original post

7 Replies
Aurelien_Martinez
Partner - Specialist II
Partner - Specialist II
Author

I have simplified polygones and it's ok but the connector have a limit?

Help users find answers! Don't forget to mark a solution that worked for you!
Ana_Yakushi
Employee
Employee

Hello Aurélien,

Could you please try to set the number to 4000 or something around that? Too big numbers may cause a problem as well.

And how big is your shapefile?

Best Regards,

Ana Yakushi

Qlik GeoAnalytics

Aurelien_Martinez
Partner - Specialist II
Partner - Specialist II
Author

Hi,

Ok thx , I will try this. My shapefile is 128 Mo.

Aurélien

Help users find answers! Don't forget to mark a solution that worked for you!
Aurelien_Martinez
Partner - Specialist II
Partner - Specialist II
Author

Hi,

I have tried 1000, 2000, 3000, 4000, 5000, 6000 but that did not works

The shapefile : https://wxs-telechargement.ign.fr/1yhlj2ehpqf3q6dt6a2y7b64/telechargement/inspire/CONTOURS-IRIS-2015...

(under \1_DONNEES_LIVRAISON_2015\CONTOURS-IRIS_2-1_SHP_LAMB93_FE-2015)

Help users find answers! Don't forget to mark a solution that worked for you!
Ana_Yakushi
Employee
Employee

Hi Aurélien,

Could you please confirm that you are using Qlikview and changing the memory parameter in this file:

C:\Program Files\Common Files\QlikTech\Custom Data\QvIdevioConnector\IdevioGeoAnalyticsConnector.exe.config

I tried with one of your shapefiles (the biggest one with 128Mb) and a 4000Mb memory setup worked fine for me.

Just as a comment, the files conforming your shapefile (.shp, .prj, etc) have to be zipped in a .zip file (not .7z).

Best Regards,

Ana

wallacechen
Creator
Creator

daccess denied.GIF

Hi Ana,

I tried to modify the geoanalytics memory to 4000 but when I  want to save it. it pop up access is denied.  can I ask how to resolve the issue? thanks

Ana_Yakushi
Employee
Employee

Hello,

Yes, that's a security issue in Windows.

You need to open the file with Notepad (or any other text editor you are using) in Administrator mode in order to be able to save the changes.

Best Regards,

Ana