Qlik Community

Healthcare

Announcements
June 28, 10AM ET: Qlik Nation and Qlik Community present: CyberSleuth REGISTER TODAY
cancel
Showing results for 
Search instead for 
Did you mean: 
alejortizp
Contributor III
Contributor III

I have a problem with data loading

Hi,

I have the same archive with diferents extensions. But when data loading with txt extension that loading less rows than xlsx extension. I dont know what happening because the xlsx is loading the right length of the archive. My objetive its loading the data with the txt extension.

Thanks if you give me a light.

1 Solution

Accepted Solutions
timpoismans
Specialist
Specialist

Try the following:

(txt, codepage is 28591, embedded labels, delimiter is '|', no quotes);


or


(txt, unicode, no labels, delimiter is ',', no quotes);



I've ran into a similar issue where the msq (checks for ") option made my file load short. No quotes seemed to fix the issue for me.

View solution in original post

6 Replies
PabloTrevisan
Partner
Partner

Hi Alejandro,

Are you impersonating the delimiter? For the qlik to know when one line ends and another starts?

It would be an initial analysis.

vamsee
Specialist
Specialist

Adding to Pablo's response Txt files always have to load with the delimiter specification. The default delimiter is ,

These might help.

LOAD data into QlikView

-- Page 6

----

QlikView Delimited File

alejortizp
Contributor III
Contributor III
Author

Hi,

I always put the delimiter specification, depends how the archive is delimited. Like that :

(txt, codepage is 28591, embedded labels, delimiter is '|', msq);

or

(txt, unicode, no labels, delimiter is ',', msq );

I dont know how resolve the problem of data loading length txt files

vamsee
Specialist
Specialist

Can you post your sample xlsx file for us to actually test the issue.2 - 3 lines should also do.

timpoismans
Specialist
Specialist

Try the following:

(txt, codepage is 28591, embedded labels, delimiter is '|', no quotes);


or


(txt, unicode, no labels, delimiter is ',', no quotes);



I've ran into a similar issue where the msq (checks for ") option made my file load short. No quotes seemed to fix the issue for me.

Lauri
Specialist
Specialist

Try also adding NO EOF to your spec:

(txt, unicode, no labels, delimiter is ',', no quotes, no eof);


This ignores end-of-file characters, which can sometimes exist erroneously in the middle of a text file. The load will stop if it sees one.