Qlik Community


Search or browse our knowledge base to find answers to your questions ranging from account questions to troubleshooting error messages. The content is curated and updated by our global Support team

QlikWorld 2022, LIVE in Denver CO., May 16-19, 2022. REGISTER NOW TO RECEIVE EARLY BIRD PRICING

AAALR is registered in the Qlik Sense logs

Showing results for 
Search instead for 
Did you mean: 
Digital Support
Digital Support

AAALR is registered in the Qlik Sense logs

The following messages will appear in the engine trace system logs:

QVGeneral: when AAALR(63.312046) is greater than 1.000000, we suggest using new row applicator to improve time and mem effeciency.
QVGeneral: - aggregating on 'RecruiterStats'(%DepartmentID) with Cardinal(87), for Object:  in Doc: ffe8a825-b52e-4ceb-aea2-30de0f2c3306

There has also been reports of end users seeing the message "Internal Engine error" when opening apps when the error above is present.

Also for QlikView see article SE_LOG: when AAALR(1072.471418) is greater than 1.000000, we suggest using new row applicator to imp...


  • Qlik Sense Enterprise on Windows, all versions


"AAALR" is a very low level concept deep in the engine. Generally speaking it means the average length of aggregation array. The longer this array is, the more memory and CPU power are to be used by the Engine to get aggregation results for every hypercube node.
When AAALR is greater than 1.0, normally the customer has a large data set and suffers slow responses and high memory usage in their app. In this case, Qlik Sense has a setting called DisableNewRowApplicator (default value is 1).
By setting this parameter to “0”, Qlik Sense will use a new algorithm which is optimized for large data set to do the aggregation, and will use much less memory and CPU power.

Changing this setting when they have AAALR warnings, making this change has resulted in drastic performance increases.

Possible setting values for DisableNewRowApplicator:

1 - Use Engine default
0 - Use new row applicator where Engine seems suitable
-1 - Force new row applicator all the time



  • Stop all Qlik Sense services from the windows control panel / services
  • Locate the “C:\ProgramData\Qlik\Sense\Engine\Settings.ini
  • Add this portion to the Engine Settings.ini file (press <enter> at the end of DisableNewRowApplicator=0 so the cursor rests on a blank line below it)

[Settings 7]
         <---- the cursor should be here when saving the file

  • Restart all Qlik Sense services
  • (If multinode) Complete the above steps on every node.



Related Content:

Labels (1)
Version history
Last update:
‎2021-10-31 07:00 PM
Updated by: