Qlik Community

Knowledge

Search or browse our knowledge base to find answers to your questions ranging from account questions to troubleshooting error messages. The content is curated and updated by our global Support team

Dynamic images do not display as chart background

Sonja_Bauernfeind
Digital Support
Digital Support

Dynamic images do not display as chart background

An API key is required to authenticate each request to Google Maps Platform. Refer to http://g.co/dev/maps-no-account for more information.

An image used as a background in a chart does not load correctly. This can be observed when a proxy is configured in the client machine. 

Images are accessible from a browser, without using any kind of authentication and Web Server Logs do not contain any errors.

Map without background.png

 

 

 

Resolution:

 

Manually add the following parameter (WebFileUseWinAPI = 1) in the Settings.ini file.

By default, the Settings.ini for QlikView Server is located at C:\ProgramData\QlikTech\QlikViewServer\Settings.ini
For QlikView Desktop is located in
C:\Users\<User>\AppData\Roaming\QlikTech\QlikView\Settings.ini

  1. Stop QlikView Services
  2. In the [Settings 7] section in Settings.ini, add the setting WebFileUseWinAPI = 1
    eg.
    [Settings 7]
    WebFileUseWinAPI = 1
    [....]
  3. Start QilkView Services


Please note that WebFileUseWinAPI = 1 setting must be entered under the [Settings 7] section. If the setting is added under the [Authentication] section, it will not be read by the QlikView Server, and will therefore not resolve the issue.

 

OR consider changing the proxy requirements: 

 

Labels (1)
Version history
Last update:
‎2021-06-01 07:17 AM
Updated by:
Contributors