Qlik Community

Knowledge

Search or browse our knowledge base to find answers to your questions ranging from account questions to troubleshooting error messages. The content is curated and updated by our global Support team

Qlik Sense Upgrade fails on remote database: This version of Qlik Sense requires a SenseServices/QSMQ database for multi cloud capabilities

cancel
Showing results for 
Search instead for 
Did you mean: 
Anonymous
Not applicable

Qlik Sense Upgrade fails on remote database: This version of Qlik Sense requires a SenseServices/QSMQ database for multi cloud capabilities

A Qlik Sense Upgrade may fail when using a standalone/remote PostgreSQL Database.

The upgrade fails the install with the following error:

This version of Qlik Sense requires a 'SenseServices' database for multi cloud capabilities. ... For more information see Installing and configuring PostgreSQL.

AND / OR

This version of Qlik Sense requires a 'QSMQ' database for multi cloud capabilities. ... For more information see Installing and configuring PostgreSQL.


Environments:

Qlik Sense Enterprise, June 2018 and later with Standalone Remote PostgreSQL database

 

Resolution


All required databases need to created prior to the upgrade:

QSR
Repository Database. This will already exist as this is the main database.

SenseServices
The new SenseService database. Introduced in June 2018.

QLogs
Logging Database. Depending on your version, this may already exist. 

QSM
Message Queuing database. Introduced in June 2018.

Licenses
The Licenses database. Introduced in April 2019.

For detailed instructions on how to install and configure PostgreSQL, see: Installing and Configuring PostgreSQL
For an example of the above with the Licenses database, see This version of Qlik Sense requires a 'Licenses' database for license capabilities. Ensure that you ...



 

Labels (2)
Version history
Last update:
‎2020-11-05 04:45 AM
Updated by:
Contributors