Skip to main content
Announcements
Live today at 11 AM ET. Get your questions about Qlik Connect answered, or just listen in. SIGN UP NOW
cancel
Showing results for 
Search instead for 
Did you mean: 
gmenoutis
Partner - Creator II
Partner - Creator II

Active Directory users cannot login

I have installed QS on my company's server. I can successfully login to hub/devhub/qmc using the root admin created during the installation process.

Then, I set up a user directory connector to an active directory. This got me the needed users visible in qmc.

Then, I went to "Licences and tokens" and allocated a license to a specific user . It now shows Status "Allocated".

Then, I went to users and added RootAdmin to this user as role (afterwards, in my desperation, I also added ContentAdmin, DeploymentAdmin and SecurityAdmin).

Despite these steps, I am unable to use this new user to login to any of hub/devhub/qmc ( I get the username-password input box reappear, as though I input something wrong), while the original user works properly.

I am using a Windows 10 desktop PC as client, and the server is Windows Server 2012. I am using Chrome to login. As a username, I have tried gm (the userid seen in qmc), DOMAIN\gm, and gm@DOMAIN.

I have thoroughly searched around for solutions, and I have tried everything that was present in this post, to no avail. There is no file at all in %Programdata%/qlik/sense/proxy.


Could you please give me a hand?

25 Replies
shraddha_g
Partner - Master III
Partner - Master III

here you will have to put windows credentials of system you are accessing this link on.

Make sure that these credentials are correct.

agigliotti
Partner - Champion
Partner - Champion

I think you should move the Qlik Sense Server from WorkGroup to Domain first as I said above.

awhitfield
Partner - Champion
Partner - Champion

Andrea is correct, from the Qlik Sense help:

Default authentication module

After a default installation of Qlik Sense, the Qlik Sense Proxy Service (QPS) includes a module that handles authentication of Microsoft Windows users. The module supports the use of Kerberos and NTLM.

If you want to use Kerberos authentication, you need to make sure that browsers that are used to access the Qlik Sense are configured to support Kerberos.

The default authentication module requires that the proxy that handles the authentication is part of the Microsoft Windows domain.

Best regards Andy

gmenoutis
Partner - Creator II
Partner - Creator II
Author

I'll need time to test/correct this, but it seems this is the case. Hope I won't have to return. Thanks!

awhitfield
Partner - Champion
Partner - Champion

Excellent, hope this sorts the issues!

Best Regards

Andy

gmenoutis
Partner - Creator II
Partner - Creator II
Author

I would like to add that after installing the server, and thus the proxy, on the domain of the active directory, indeed everything worked. Thank you all very much!