Skip to main content
Announcements
Live today at 11 AM ET. Get your questions about Qlik Connect answered, or just listen in. SIGN UP NOW
cancel
Showing results for 
Search instead for 
Did you mean: 
ashokpaladugula
Contributor III
Contributor III

How to apply ssl(.crt file) to QlikSense server

     Hi All,

How to apply the ssl certificate qlik sense server.

Qlik sense Non Secure.png

Thanking you,

ASHOK

stalwar1swuehlhicjmc

25 Replies
JustinDallas
Specialist III
Specialist III

Do you have the certificate already?  Or are you starting from the point where you generate a Certificate Signing Request?

agigliotti
Partner - Champion
Partner - Champion

first you have to generate a CSR (Certificate Server Request) and submit it to a CA to get back the SSL certificate with the private key.

After that take a look at Installing SSL certificate on Sense server

ashokpaladugula
Contributor III
Contributor III
Author

Yes. I have a certificate already.

Thanking you,

ASHOK

JustinDallas
Specialist III
Specialist III

Then if you already have the cert created, you will probably want to follow the directions listed in the post linked by Andrea Gigliotti. 

ashokpaladugula
Contributor III
Contributor III
Author

Hi,

I followed these steps. but no result.

"Received from domain CA certificate on the server. If not necessary to, I will describe how to do this.

further open the properties of the certificate, tab "details" option "Thumbprint"

and copied value as is, with spaces.

Edit Proxy, check Security and paste value in "SSL browser certificate thumbprint" with space.

Restart Qlik Sense Web Server"

Thanking you,

ASHOK

agigliotti
Partner - Champion
Partner - Champion

you have to remove spaces in your Thumbprint string and then paste it in "SSL browser certificate thumbprint" under proxy settings.

after restart the Qlik Sense Proxy Service.

Anonymous
Not applicable

I have never removed spaces in the Thumbprint and it has always worked for me.

agigliotti
Partner - Champion
Partner - Champion

yes you right Bill, I checked it right now and the string contains spaces.

ashokpaladugula
Contributor III
Contributor III
Author

I didn't remove the spaces, but it is not working for me.