Skip to main content
Qlik Connect 2024! Seize endless possibilities! LEARN MORE
Showing results for 
Search instead for 
Did you mean: 
Contributor III
Contributor III

Qlik sense desktop / issue to write on Google Drive


Here's my issue : in Qlik sense desktop
I load data from a Google Drive.
I want to write back on Google Drive using the same connexion string (different file name)

I get an error message : 

(system engine log)
WARN 20230307T131425.487+0100 28980 27016 Personal\Me default f25b1846-b29b-44d1-a804-2adc18b59dd8 0 20230307T114029.000+0100 CGenericConnection: pipe[\\.\pipe\data_5749a40b4c9e152a380ec261345f7ec65e95e604.pip] message Invalid query: STORE [F_DEPOT] INTO [lib://Google_Drive - aaaaa@aaaaaaa.fr2/1Ky4p-PKaXXXXXXXM40LLSzc-7t7kJdH9/F_DEPOT1.qvd] (qvd)

(script log)
20230307T131713.613+0100 0066 STORE [F_DEPOT]
20230307T131713.613+0100 0067
20230307T131713.613+0100 0068
20230307T131713.613+0100 0069 INTO [lib://Google_Drive - aaaaa@aaaaaaaa.fr2/1Ky4p-PKaXXXXXXXM40LLSzc-7t7kJdH9/F_DEPOT1.qvd]
20230307T131713.613+0100 0070 (qvd)
20230307T131714.036+0100 Error: Cannot open file: 'lib://Google_Drive - aaaaa@aaaaaaa.fr2/1Ky4p-PKaQ3ZQRSwM40LLSzc-7t7kJdH9/F_DEPOT1.qvd' (Native Path: qfilestream://1Ky4p-PKaXXXXXXXM40LLSzc-7t7kJdH9/F_DEPOT1.qvd
20230307T131714.036+0100 System error: noFileSize)
20230307T131714.036+0100 Execution Failed
20230307T131714.037+0100 Execution finished.

Any clue ?


Attached : Google rights allowed to Qlik 



Labels (1)
4 Replies
Partner - Specialist
Partner - Specialist

for the log files I would say that you tried to load a file that doesn't (yet) exist. so qlik tries to look for the file but can't find it. it would be helpfull if you can  show  the entire script? this will help debugging a lot easier

Contributor III
Contributor III

Thanks for this answer.
Howerver, i'm not trying to load, but to store a table in a new file.

I load a file in a directory / I reuse the same path that worked fine on loading to store the result in another file.

This works fine on a local drive, but not for google drive using qlik sense desktop.
It works fine with qlik SAAS (I can write in the directory)
But as my data source is on a local network that I can only access with a VPN, I can't use Qlik SAAS

Thanks again



Partner - Contributor III
Partner - Contributor III

Did you solve this issue?

Contributor III
Contributor III

No, I gave up
I generated the qvds locally and launch a batch to copy on Google drive (with latency since I use the Windows app for Google drive emulation which replicates files)