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In QlikView November 2018 and Later Releases, Export to Excel CSV Format Results in Fields Being Separated by Semicolon

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In QlikView November 2018 and Later Releases, Export to Excel CSV Format Results in Fields Being Separated by Semicolon

Last Update:

Aug 25, 2021 3:34:44 PM

Updated By:

Andre_Sostizzo

Created date:

Feb 19, 2019 9:13:26 AM

Environment:

QlikView, versions November 2018 and above

 

Description:

In QlikView, November 2018 release and later, the Export to Excel CSV format may result in the fields being separated by a semicolon instead of a comma.

 

Cause:

QlikView November 2018 introduced the use of International Components for Unicode (ICU) libraries. More information regarding ICU libraries can be found in the online QlikView Help.

QlikView May 2021 has a defect (ID ID QV-22407) that affects the parameter mentioned in the resolution below, so if the resolution was applied on a previous version, the issue resurfaces on May 2021.

 

Resolution:

Note: The resolution applies only to versions prior May 2021, in which a defect was found (ID QV-22407) which affects the resolution below. 

This issue is typically resolved by editing the QlikView Server Settings.ini file and entering UseIcuForLocaleInfo=0

Please see the below steps on how to include this setting:

  1. Stop the QlikView Server Service (QVS) on all nodes running QVS
  2. Open a text editor such as Notepad++ as with administrator privileges
  3. Navigate to the QlikView Server Settings.ini file in %ProgramData%\QlikTech\QlikViewServer
  4. Add UseIcuForLocaleInfo=0 underneath the [Settings 7] section. ***Please note that if the setting is added under the [Authentication] property, it will not be read by the QlikView Server Service.***
  5. Save the Settings.ini file
  6. Restart the QVS nodes

Also, be sure that the comma is set as List Separator in your operating system regional settings. To do this:

  1.  Log on to the QlikView server as the QlikView service user
  2.  Open the Control panel and go to "Regional"
  3.  Click on the "Additional Settings..." button in the "Formats" window
  4.  Choose the correct list separator
  5.  Restart the machine

See the image below. Note in the Customize Format screen that the List separator is set as a semi-colon ";" therefore it would need to be changed to a comma ",".  When making changes to these values, a reboot of the server is necessary.

1.png

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Last update:
‎2021-08-25 03:34 PM
Updated by: