Skip to main content

Official Support Articles

Search or browse our knowledge base to find answers to your questions ranging from account questions to troubleshooting error messages. The content is curated and updated by our global Support team

Announcements
NEW webinar Dec. 7th: 2023 Outlook, A Pivotal Year for Data Integration SIGN ME UP!

Qlik Sense's compatibility with PostgreSQL for the Repository Database

cancel
Showing results for 
Search instead for 
Did you mean: 
Andre_Sostizzo
Digital Support
Digital Support

Qlik Sense's compatibility with PostgreSQL for the Repository Database

What versions of PostgreSQL does Qlik Sense support?

For up to date information, please verify against your Qlik Sense version on help.qlik.com: System Requirements 

 

Qlik Sense Version: PostgreSQL version

 

Sense May 2021 is compatible with PostgreSQL 9.6.x, 11.x and 12.5 (included)

Sense February 2021 PostgreSQL 9.6.x (included in the installer), 11.x (not included in the installer), 12.x (not included in the installer, must not be used with Centralized logging )
Sense February to November 2020 is compatible with PostgreSQL 9.6.x (included), 11.x
Sense November 2019 is compatible with PostgreSQL 9.6.x (included), 11.x
Sense September 2017 is compatible with PostgreSQL version 9.6.x
Sense June 2017 is compatible with PostgreSQL version 9.6.x
Sense 3.2 is compatible with PostgreSQL version 9.3.x and 9.6.x
Sense 3.1 is compatible with PostgreSQL version 9.3.x

​​​​​​​Verify used version:

  1. Open the Repository configuration file (default path C:\Program Files\Qlik\Sense\Repository\Repository.exe.config)
  2. Find the Devart.Data.PostgreSql version:

    repository exe config.png
  3. Reference the dependency's version history to determine which version of PostgreSQL is supported by the module's version.
Labels (1)
Comments
mk_kmx
Partner - Contributor III
Partner - Contributor III

Just a quick note - when using Centralized logging, another copy of Devart library is used. And when I was checking that few months ago (09-10/2020), it was (surprisingly) other than the one used in Repository. Unfortunately, much older.

mk_kmx_0-1609755213223.png

 

@Andre_Sostizzo is this "as expected"?

Version history
Last update:
‎2022-08-26 03:20 PM
Updated by: