Skip to main content

Qlik NPrinting

Discussion Board for collaboration on Qlik NPrinting.

Announcements
Defect acknowledgement with Nprinting Engine May 2022 SR2, please READ HERE
cancel
Showing results for 
Search instead for 
Did you mean: 
bnaveen
Partner - Contributor
Partner - Contributor

How to set Default Report Timeout in NPrinting

Hi,

Is there a default setting/configuration to abort the NPrinting report request if it is running for a long time?

Sometimes requests are taking a really long time for months and unless we manually check and abort, we are not able to stop them. If there is a way to fail a report if not processed after X minutes/hours that would really help.

I couldn't find anything in the documentation. Appreciate any help on this.

Qlik NPrinting @QlikNPrintingUpdates @nprinting 

Thanks

Labels (2)
2 Solutions

Accepted Solutions
Frank_S
Support
Support

Hi @bnaveen

Not certain about your version of NPrinting but I did check May 2021 SR 3 and the following settings are available in the scheduler.config file found in:

  • "C:\Program Files\NPrintingServer\NPrinting\Scheduler"
 Scheduler options
 =================
 -->
 <!-- <add key="report-timeout-minutes" value="720" /> -->
 <!-- <add key="generate-cache-timeout-minutes" value="720" /> -->

Steps:

  • Stop the NPrinting services
  • uncomment this line 
    <!-- <add key="generate-cache-timeout-minutes" value="720" /> -->​
  • Uncommented
     <add key="generate-cache-timeout-minutes" value="720" />
  • Adjust the time as needed
  • Start your NP services.

 

There is better timeout management in the newer version so I would suggest upgrading to the latest release of NPrinting as this might solve the issue entirely or at least you can manage the timeouts as per above.

 

Kind regards...

We are just 'like' you and like to be liked when providing a helpful answer. You may also press the 'Solution Accepted' button if an answer provided resolves your question or issue... Cheers!

View solution in original post

Frank_S
Support
Support

R&D has provided a deep-detailed answer in which I will summarize here.

 

While there are no lower limits, these timeout settings are essentially present to handle very specific scenarios. Mainly incrementing the default timeouts in order to allow NPrinting, Qlik Sense or QlikView servers that might be overburdened temporarily, to complete NPrinting executions (on demand, report task, connection processing etc). 

 

*The primary intention of these settings therefore is not to cause a 'fail' or 'abort' of any NPrinting executions but to allow valid, long running execution to complete.*

 

In a nutshell, lowering these values is not suggested. Increasing them will allow NPrinting reports to generate if the system is temporarily overburdened or if they simply require more time to complete. 

 

However, if you need to force the abort of a report execution, this can be managed by the end-user or by the NPrinting administrator as per the following articles.

 

Now if your systems are consistently overburdened, then it is advised to setup performance monitoring of each of your Qlik Server's CPU, RAM, and Disk usage. If any or all are consistently maxing out, it is recommended to add system resources to accommodate any increased load on your existing servers.

 

You may also consider improving the performance of your report itself which may include:

  • avoiding heavy use of cycles
  • ensure to carefully follow filter rules
  • ensuring there are no calculated dimensions in your source QVW or QVF
  • reduce your QVW or QVF for NPrinting reporting purposes
  • remove unneeded objects from your reporting QVW or QVF
  • remove the unsupported object from your QVW or QVF

Should you need assistance with more detailed requirements in configuring your Qlik Architecture, you may wish to connect with your Qlik Account or Partner manager to leverage the vast experience of our professional services team.

 

Kind regards...

 

We are just 'like' you and like to be liked when providing a helpful answer. You may also press the 'Solution Accepted' button if an answer provided resolves your question or issue... Cheers!

View solution in original post

13 Replies
Frank_S
Support
Support

Hi @bnaveen

Not certain about your version of NPrinting but I did check May 2021 SR 3 and the following settings are available in the scheduler.config file found in:

  • "C:\Program Files\NPrintingServer\NPrinting\Scheduler"
 Scheduler options
 =================
 -->
 <!-- <add key="report-timeout-minutes" value="720" /> -->
 <!-- <add key="generate-cache-timeout-minutes" value="720" /> -->

Steps:

  • Stop the NPrinting services
  • uncomment this line 
    <!-- <add key="generate-cache-timeout-minutes" value="720" /> -->​
  • Uncommented
     <add key="generate-cache-timeout-minutes" value="720" />
  • Adjust the time as needed
  • Start your NP services.

 

There is better timeout management in the newer version so I would suggest upgrading to the latest release of NPrinting as this might solve the issue entirely or at least you can manage the timeouts as per above.

 

Kind regards...

We are just 'like' you and like to be liked when providing a helpful answer. You may also press the 'Solution Accepted' button if an answer provided resolves your question or issue... Cheers!
Frank_S
Support
Support

But keep in mind that when upgrading, all config file changes are lost so you will need to document the changes.

Also make sure to make a backup copy of the scheduler.config file before making any changes to the original.

Kind regards...

We are just 'like' you and like to be liked when providing a helpful answer. You may also press the 'Solution Accepted' button if an answer provided resolves your question or issue... Cheers!
bnaveen
Partner - Contributor
Partner - Contributor
Author

Thank you @Frank_S . This really helps. Yes, we are in the process of  upgrading to the latest version but this would help in the meantime. 

bmulvanyw
Partner - Contributor
Partner - Contributor

Hello, @Frank_S 
I am trying to implement this setting, but after following your steps and setting the timeout to 1 minute for testing it doesn't stop the report after running more than a minute.

I am trying to apply this setting for on-demand NPrinting reports and these are the three different settings I have tried to use:

scheduler.config:

 

=========================================
Scheduler options
=========================================
-->
<add key="report-timeout-minutes" value="1" />
<add key="generate-cache-timeout-minutes" value="1" />
<add key="ondemand-timeout-minutes" value="2" />
<!-- <add key="search-value-timeout-minutes" value="10" /> -->

 

 

bmulvanyw_1-1651167543769.png


I am trying this in :

Qlik NPrinting May 2021 SR1
Version: 21.14.4.0

Frank_S
Support
Support

Hi @bmulvanyw

 

What would be the purpose of setting these values so low? (this would be the first question from R&D)

 

In any case, there 'might' be a floor value like 100 minutes for example. 

I will ask R&D and come back here with a response as soon as I receive one. (R&D is in europe so earliest answer would be tomorrow or early next week.

 

Kind regards...

We are just 'like' you and like to be liked when providing a helpful answer. You may also press the 'Solution Accepted' button if an answer provided resolves your question or issue... Cheers!
Frank_S
Support
Support

Actually @bmulvanyw

 

Regarding your statement "I am trying to implement this setting, but after following your steps and setting the timeout to 1 minute for testing it doesn't stop the report after running more than a minute". Do you mean 'Report Preview' in the NP designer is not aborted or the 'NP Publish Task that report is contained in' is not aborted?

 

I will need to know this before I reach out to R&D.

 

Let me know...thx.
 

We are just 'like' you and like to be liked when providing a helpful answer. You may also press the 'Solution Accepted' button if an answer provided resolves your question or issue... Cheers!
bmulvanyw
Partner - Contributor
Partner - Contributor

Appreciate the reply. The low value was meant just for testing out the setting to see that it worked for our need. We don't normally have such long running reports, so the 1 minute was just to test the config setting. If there is a minimum value you find out I can try that.

This isn't for the designer or publish task, we want to abort any long running "On-Demand" requests. The elapsed time I highlighted from my last reply was from this page:

bmulvanyw_0-1651175598140.png

 

Frank_S
Support
Support

Ok the picture is clearer.

 

It is my understanding that those values will come into play only if an On Demand report or just a report in a publish task, hangs in the background, rather than for forcing aborts of valid, running task or on demand executions.

 

So these settings in scheduler.config shouldn't affect valid, On Demand report or publish task executions.

 

How do you check for hangs? 
There is a hidden link in the NP web console. You can view this for hangs. That is if there is no change in the values for the execution in the background ie: the admin plan, this would be considered a 'hang'  by the scheduler service and the scheduler service would count in minutes (defined in the scheduler.config) essentially when scheduler service determines the process to be stuck then abort the tasks or On Demand execution. So if you have it set the scheduler.config file to a minute timeout, then the scheduler service should abort a hung report after a minute of identifying it as a 'hung' execution.

 

The admin plan address is https://mynprintingserver:4993/#/admin/plan (replacing the name of your NP server over 'mynprintingserver')

 

You can manually abort On-Demand reports however if you feel they need to be exited. 

See Managing On-Demand requests

 

cc @Ruggero_Piccoli can you add to this when you have a moment - if needed, thanks!

We are just 'like' you and like to be liked when providing a helpful answer. You may also press the 'Solution Accepted' button if an answer provided resolves your question or issue... Cheers!
Frank_S
Support
Support

ps: the admin plan is a hidden link normally reserved for use with R&D and any necessary advance troubleshooting which may be required. It is not meant to act as a system monitor. For that, you can check out the NPrintingGovernance Dashboard here:

Qlik NPrinting Governance Dashboard - Version 3 Now Available

We are just 'like' you and like to be liked when providing a helpful answer. You may also press the 'Solution Accepted' button if an answer provided resolves your question or issue... Cheers!