Qlik Community

QlikView Administration

Discussion Board for collaboration on QlikView Management.

Announcements
Now Live: Qlik Sense SaaS Simplified Authoring – Analytics Creation for Everyone: READ DETAILS
cancel
Showing results for 
Search instead for 
Did you mean: 
Not applicable

Custom Login Page

I have two departments, and each one must have a personalized login and access point page (different logos).

I have made those changes:

On Management Console:

     Set the Web Server Authentication to custom login page (./FormLogin.htm)

     Add two folders (Dep1 and Dep2) each one with its own path

I used as base the default "C:\Program Files\QlikView\Web" folder to create the folder for each department

On each path, changed the images bg_login.png and bg_login.png

Change the form action on each FormLogin.htm to:

/QvAJAXZfc/Authenticate.aspx?back=/Dep1/FormLogin.htm

/QvAJAXZfc/Authenticate.aspx?back=/Dep2/FormLogin.htm

The problem is that the Authenticate.aspx always redirects to /qlikview/index.htm. I also tried to change the form action on FormLogin.htm to "/QvAJAXZfc/Authenticate.aspx?back=/Dep1/index.htm" with no success

Labels (1)
1 Solution

Accepted Solutions
Not applicable
Author

Finally solved by myself:

added this javascript code to the index.html file in the qlikview folder:

document.location.href = document.referrer.lastIndexOf('/') + '/Index.htm';

View solution in original post

7 Replies
vikasmahajan

I think you need to go through An introduction to QlikView Security using Web Tickets

discussion.

Or  you can implement Iframe for two diff depts. in html you need to code

<HTML>

<H1>Wel Come to Qlikview</H1>

</ul>

<iframe height='600' width='1200' src='http://100.0.7.15/QvAJAXZfc/opendoc.htm?document=Indoco_PnO.qvw&host=QVS@qlikviewserver' frameborder='0'></iframe>

</HTML>

Save in 2 diff html.

Vikas

Hope this resolve your issue.
If the issue is solved please mark the answer with Accept as Solution.
If you want to go quickly, go alone. If you want to go far, go together.
Not applicable
Author

Finally solved by myself:

added this javascript code to the index.html file in the qlikview folder:

document.location.href = document.referrer.lastIndexOf('/') + '/Index.htm';

Not applicable
Author

Hi

how do you set the page in the  custom login page field on server ?

i'm trying to set a file and i't not works.

thank you

Not applicable
Author


On the Management Consolo:

System -> Setup -> Management Service -> QlikView Web Server -> QVWS@server -> Autenthication -> Login Address

Select the radio "Custom login page" and a textbox appears

danilodct
Contributor III
Contributor III

I have the same problem of Ramon Rios . I putted a HTML file on WEB default folder, as you, and setted up the custom login page, but when accessing i got: "Failed to authenticate"

Salvador Arnal Julian you just setup the custom login page or had you setup "Authentication Type" (NTML; Header; Custom User) and "Authentication" (Always; Login; Never)?

And what about the Server Security Configuration? What had i put on "Authentication Clients" option, "Authorization"?

Thankss

Not applicable
Author

Hi,

I have configure Active Directory to manage the users login.

I have attached captures with my actual configurationCapt01.PNG.pngCapt02.PNG.pngCapt03.PNG.png

The FormLogin.htm is the same that comes with Qlikview (On C:\ProgramFiles\QlikView\Web\), I only changed the Images.

rbalatbat
Contributor II
Contributor II

Hi s.arnal.qv

Good you give me a complete walkthrough how you where able to accomplish this?

please do email at gb2_gb3@yahoo.com

Thanks and Best Regards,