Skip to main content

QlikView Administration

Discussion Board for collaboration on QlikView Management.

Announcements
QlikWorld 2023, a live, in-person thrill ride. Save $300 before February 6: REGISTER NOW!
cancel
Showing results for 
Search instead for 
Did you mean: 
Not applicable

QlikView macro security

Hello everybody,

I have a question regarding the QV macro security settings.

In our server configuration, there is no execution of unsafe macros allowed:

server.png

However, if I open a document, I'll get this message

Module_Security.png

and after selecting "Allow any macro", the unsafe macro works very fine. So my question is: What is the server config for, if I can

start unsafe macros anyway?

PS: We run QV 10.

9 Replies
danielrozental
Master II
Master II

There is no server config for that, is a client based setting.

Not applicable
Author

Hi.

What if the user did a mistake and when the "Module Security for Document" window appeared he chose the wrong option (say Disable when he actually needed to tick Allow).

How can we make the window re-appear? Is there a browser option to clear the preference and allow the user to go for another option?

Thanks

Fabrizio

m_woolf
Master II
Master II

Shift+Ctrl+M

Not applicable
Author

Thank you.

I thought that Shift+Ctrl+M was the key sequence for QlikView Desktop only, but I see it works in IE running the IE plugin too.

Anyway, the windows is not the same as the one that appears the first time a user opens a report in IE (the one shown in the original post from jensweinsheimer).

The window that appears after Shift-Ctrl+M is named "Change Module Security" and looks like this:

sec.PNG

Is there a way to get IE to show the original "Module Security for Documents" form?

Regards

Fabrizio

mr_janne
Contributor III
Contributor III

On the user machine (not the server) go to the folder C:\Users\<username>\AppData\Roaming\QlikTech\QlikView

There you can find a file named: Settings.ini

Scroll to the end of that file and find a list of checksums for documents. The list starts right after this line:

[Module Checksums System]

Remove all checksums, restart the browser and you should see the security module again.

regards

Not applicable
Author

Hi Mr_Jane,

I Did exactly the same steps mentioned by you in above post.I works fine.

Can you please explain what is the meaning of

[Module Checksums System] ??

Thanks,

Kiran

mr_janne
Contributor III
Contributor III

Hi!

"When you select the "Allow any Macro (only for trusted documents)" setting in the Module Security for Document dialog box, the user will write an entry into their Settings.ini file for future reference when accessing the same document again that looks like this:

ie.
[Module Checksums System]
A9482042-C9C84715-6AC72FD3-CC60CE86-7C39299B=

The Module Checksums System lists all the checksums for the applications where you have picked "Allow any Macro...".

The checksum is unique for each application, so after you've set this for one user, you can copy the checksum and paste it in the different users' Settings.ini files and QlikView will open up the application allowing macros without prompting the users."

Original forum topic can be found here:

http://community.qlik.com/message/308715

Hope that helps!

regards. Janne

elkis1006
Contributor
Contributor

Hi Mr Jane,

What if the user machine is a Windows XP SP3? Believe it or not, it's that.

Where Can I find that file? ....."Settings.ini"

The Qlikview version es 9.0.

Regards!

mr_janne
Contributor III
Contributor III

Hi!

I think prior to the 10 version, settings were stored in the windows registry.

So you have to start regedit and do this stuff:

HKEY_CURRENT_USER--> SOFTWARE--> QLIKTECH--> QLIKOCX

-->delete the folder MODULE CHECKSUMS SAFE

regards. Janne