Skip to main content

QlikView App Dev

Discussion Board for collaboration related to QlikView App Development.

Announcements
QlikWorld 2023, a live, in-person thrill ride. Save $300 before February 6: REGISTER NOW!
cancel
Showing results for 
Search instead for 
Did you mean: 
partenope
Partner - Creator II
Partner - Creator II

How to reset Macro authorizations

Hi all,

when a new QV document with Macro inside is opened by a user, a pop-up asks him witch level of security he wants to set. Normally all users choose a wrong level and set a flag "save this value".

when it happens, the user can never change this parameter!

there is "ctrl+shift+M" key combination to reset temporarily the security, but at each new open the security value returns like first selection.

there is a way to re-set security value and ask again to the user the macro security level?

thanx, Dario

1 Solution

Accepted Solutions
mov
Employee
Employee

Dario,
User's choice goes to the registry, see under ...\QlikTech\QlikView\ for checksums - there could be Block, Safe, and System, as I can recall. Delete all them completely, and after this user will have to re-enter the choice again.

View solution in original post

7 Replies
mov
Employee
Employee

Dario,
User's choice goes to the registry, see under ...\QlikTech\QlikView\ for checksums - there could be Block, Safe, and System, as I can recall. Delete all them completely, and after this user will have to re-enter the choice again.

Not applicable

Dario,

At plugin install time we runa little vbs script which sets the registry to always trust the server - change 'myserverid' as appropriate:

Dim WshShell

Set WshShell = WScript.CreateObject("WScript.Shell")

' It does not matter if this is run more than once as it will just overwrite existing values
WshShell.RegWrite "HKCU\Software\QlikTech\QlikOcx\Settings for Qlikview Servers\", 1, "REG_SZ"
WshShell.RegWrite "HKCU\Software\QlikTech\QlikOcx\Settings for Qlikview Servers\Module Script System\", 1, "REG_SZ"
WshShell.RegWrite "HKCU\Software\QlikTech\QlikOcx\Settings for Qlikview Servers\Module Script System\myserverid", "", "REG_SZ"

WScript.Echo "(: Macros are now enabled :)"

Regards,

Gordon

partenope
Partner - Creator II
Partner - Creator II
Author

I'll try,

thanx to all!

m_woolf
Master II
Master II

What do you mean by "Server ID?"

erichshiino
Partner - Master
Partner - Master

Hi,

Is it still the only way to reset those settings?

Regards,

Erich

mov
Employee
Employee

Erich,

It is different in Windows 7.  See file

C:\Users\USERNAME%\AppData\Roaming\QlikTech\QlikView\Settings.ini

The file is structured much the same as the registry settings.

Regards,

Michael

PS: For some reason, I don't receive notifications about posts in the older threads.  It is safer to start new.

erichshiino
Partner - Master
Partner - Master

I guess I got lucky!

Thank you a lot!

Erich