Skip to main content

QlikView App Dev

Discussion Board for collaboration related to QlikView App Development.

Announcements
QlikWorld 2023, a live, in-person thrill ride. Save $300 before February 6: REGISTER NOW!
cancel
Showing results for 
Search instead for 
Did you mean: 
erikajain02
Contributor II
Contributor II

Protocol Error in TDS Stream

Hi All,

I Have upgraded my Qlikview server and Desktop from Version Qv 11 Sr 2 to Qv 11 Sr 9.

After this change some of my reloads of Application are failing from QMC at Stage1 (which means When I am fetching the data from Database SQL).

When I am Trying to fetch the data 1st time it fails giving the following Error:

SQL##f - SqlState: S1000, ErrorCode: 0, ErrorMsg: [Microsoft][ODBC SQL Server Driver]Protocol error in TDS stream

SQL SELECT *

  FROM AirReconLive.dbo."tbl_SalesHeader"


2nd time when I reload it , it Succeeds without giving any error.


Please help !!!!


Regards

Erika






1 Solution

Accepted Solutions
Not applicable

Hi,

I got the similar issue here and will investigate further...

View solution in original post

8 Replies
Not applicable

Hi,

I got the similar issue here and will investigate further...

Not applicable

Hi,

This is what I heard from Qlik Support below. So, update the ODBC Driver to the Latest one and it should help...

ProtocolError.JPG.jpg

jpapador
Partner - Specialist
Partner - Specialist

This issue is really annoying.  Like the replies above it is an ODBC driver issue.  Try updating the driver or connecting via OLEDB and see if the issue persists.

schivet
Contributor III
Contributor III

Hi Erika,

I had exactly the same problem. Now I have updated the ODBC Driver and it work as before:

2015-01-14_Image 011.jpg

Not applicable

Hi friend.

I had the same problem. I think the issue is about the ODBC Drive. Try to connect using OLEDB direclty.

This solved my problem.

See ya!

admin1
Contributor III
Contributor III

Hi,

Updated the driver, but no succes...
It keeps giving the same error.

SQL##f - SqlState: S1000, ErrorCode: 0, ErrorMsg: [Microsoft][ODBC SQL Server Driver]Protocol error in TDS stream

With the Debugger on it gives a little bit more information,

SQL##f - SqlState: S1000, ErrorCode: 0, ErrorMsg: [Microsoft][ODBC SQL Server Driver]Protocol error in TDS stream: SQL SELECT * FROM topdesk.dbo.incident WHERE status <>'-1'


It is more but still not enough to get it sorted.


Any ideas ... can't find a solution online.


admin1
Contributor III
Contributor III

Hi,

I've been fiddling with this the rest of the weekend.

And I moved to OLE DB in stead of ODBC and that works like a charm...

I guess... ODBC is just not the way to go.

gr.

Armin

nedcliqs
Contributor III
Contributor III

I was struggling with the same  error, OLE DB worked. Thanks arminkorb