Qlik Community

Ask a Question

Brasil

Announcements
Join us March 10th, 7 Ways Modern Analytics Can Help You Take Smarter Action. REGISTER NOW
cancel
Showing results for 
Search instead for 
Did you mean: 
Not applicable

Problema ao exportar para Excel via browser

Galera, bom dia!

O usuário está tentando exportar uma tabela em .csv e quando finaliza a exportação, abre uma nova aba com o csv. Simulei na minha máquina e o mesmo está ocorrendo, seja pelo Chrome ou IE.

Alguém sabe o por quê de não abrir para salvar em um arquivo e sim em uma nova aba?

1 Solution

Accepted Solutions
Not applicable

Galera, era quantidade de linhas mesmo!

Não eram 6k, 6k era o que vinha pro csv...ela estava tentando exportar quase 1kk...aí ferra a memória, né?

View solution in original post

13 Replies
Not applicable

detalhe: para uma consulta menor, abre o pop-up perguntando o que quero fazer, se salvar em arquivo e tudo mais. A seleção retorna quase 6K de linha e demora algo próximo de um minuto. Já a outra seleção demora uns 5 segundos pra exportar, com quase 3K de linhas...

alguém tem ideia?

Clever_Anjos
Employee
Employee

Você está utilizando a opção Exportar?

Sem título.png

Not applicable

Não! Usando o botão que fica na barra mesmo! Mas clicando no "Send to Excel" ocorre o mesmo. Idem a opção "Export..."

Clever_Anjos
Employee
Employee

No meu servidor, exportando 20 mil linhas fica assim.

É assim que não quer?

Capturar.PNG.png

Not applicable

assim que quero! que abra pra salvar assim, ou salve direto se estiver configurado no rowser.

Ele tá abrindo assim:

2013-10-31_11h23_44.png

Clever_Anjos
Employee
Employee

Como estão as propriedades do usuário na aba Export?

Sem título.png

Not applicable

é pelo browser, portanto acredito que não influencie, certo? Pois os usuários não têm acesso ao arquivo QVW. Como é uma configuração de usuário e não do documento, se eu mudasse algo só faria diferença pra mim, certo?

De qualquer maneira, está igual, exceto está com ANSI e tem uma opção a mais no "Send To Excel Options" que é: "Usar Configuração Regional Para Enviar ao Excel".

Clever_Anjos
Employee
Employee

É possivel você embaralhar os dados e me mandar a app? Vou testar no meu server aqui

fabio_vallone
Creator
Creator

Já me ocorreu isso, e sumiu sem nenhuma intervenção. Penso que talvez seja o gerenciamento de memória cache do windows, depois de usar muitos painéis. Experimenta reiniciar o processo do qlikview, entra no servidor, executa o CMD como administrador e digita:

> net stop qlikviewserver

> net start qlikviewserver

Obs: se alguém estiver usando melhor não fazer isso.