Qlik Community

Ask a Question

App Development

Discussion board where members can learn more about Qlik Sense App Development and Usage.

Announcements
April 22, 2PM EST: Learn about GeoOperations in Qlik Sense SaaS READ MORE
cancel
Showing results for 
Search instead for 
Did you mean: 
xufei123
Partner
Partner

REST connector stops working in Sense 3.0

It is still working for my QlikView.

After I upgraded my Sense to 3.0. it stopped working. Test connection still said successful but cannot load any data.

Does anyone know when the new version of REST connector that can work with Sense 3.0 will be release?

Thanks.

Fei

1 Solution

Accepted Solutions
Dustin_Baxa
Employee
Employee

Hi Fei,

Are you using desktop? If you had the REST connector installed prior to upgrading to 3.0 (which now has a REST connector built in) then it is possible that the new REST connector did not install properly, and perhaps Sense is trying to use that new connector. Try uninstalling the Qlik REST connector that you installed previously via the Add/Remove programs, uninstall 3.0, and then reinstall 3.0.

Good luck!

Dustin

View solution in original post

8 Replies
Not applicable

Hi, I've got the same issue.. Anybody knows when this will be fixed?

Did you raise a ticket about this by the way?

lucasmagalhaes
Partner
Partner

Hi, xufei123

It's seems that REST connector is already native on Qlik Sense 3.0 so you don't need a new version of it.

Maybe you need to reconnect the connection using the native REST connector.

Let me know if this works.

Lucas Magalhães

+55 (11) 3090-5557

Paralelo CS

Dustin_Baxa
Employee
Employee

Hi Fei,

Are you using desktop? If you had the REST connector installed prior to upgrading to 3.0 (which now has a REST connector built in) then it is possible that the new REST connector did not install properly, and perhaps Sense is trying to use that new connector. Try uninstalling the Qlik REST connector that you installed previously via the Add/Remove programs, uninstall 3.0, and then reinstall 3.0.

Good luck!

Dustin

View solution in original post

xufei123
Partner
Partner
Author

Yes Dustin, I installed REST connector before I upgraded Sense to 3.0. I'll try per your suggestion and let you know if it works.

Thank you very much!

Fei

xufei123
Partner
Partner
Author

Sorry one question. The REST connector is working for QlikView now. If I remove it and reinstall Sense 3.0, the REST in Sense could work. However I might need to install REST connector again to make QlikView REST work. Will that then affect the REST in Sense?

I just want to make sure REST is working for both QlikView and Sense desktop...

Cheers

Fei

Dustin_Baxa
Employee
Employee

Hi Fei,

I don't know the answer to that question, but I would assume that it would not affect the REST in Sense since the new native REST would have been successfully installed.

Dustin

xufei123
Partner
Partner
Author

Hi Dustin,

I have uninstalled REST connector, then uninstalled Sense 3.0.

After reinstalling Sense 3.0, the REST coming with Sense is working!

I then installed the REST connector, after that QlikView REST is working. The Sense is not affected and it is still working.

So all working as you expect.

Thank you very much!

Cheers

Fei

Dustin_Baxa
Employee
Employee

Excellent! Glad I could help.