Skip to main content

App Development

Discussion board where members can learn more about Qlik Sense App Development and Usage.

Announcements
An issue has been identified on Qlik Cloud hub, please visit our Status Update Page for details: GET THE LATEST
cancel
Showing results for 
Search instead for 
Did you mean: 
inmemoryofER
Contributor II
Contributor II

Run chart "year" disappears on x-axis when measure = 0

I have a table like so:

Year ID
2018 43636
2018 26436
2019 74573
2020 34264
2020 45673
2020 21355
2021 45727
2021 23456

 

I would like to make a run chart with 'year' as the dimension and count(distinct ID) as the measure. Unfortunately, when the data is filtered in a way that the count for a specific year is 0, the year disappears from the x-axis entirely, rather than displaying 0 or leaving a gap (see attached screenshot). I've tried checking "Include Zero Values" under "data handling" as well as playing with the options under "missing values" in "Appearance". I also tried converting the "year" in the load script to the "first day of the year" (i.e. '2019' becomes '2019-01-01') and then using the autocalendar. This sort of worked, but caused other issues. Does anyone have any advice?

Labels (1)
0 Replies