Qlik Community

Ask a Question

App Development

Discussion board where members can learn more about Qlik Sense App Development and Usage.

Announcements
April 22, 2PM EST: Learn about GeoOperations in Qlik Sense SaaS READ MORE
cancel
Showing results for 
Search instead for 
Did you mean: 
patriciousa
Creator II
Creator II

Sum and show only values greater than #

Hi community.

I have this sum right now:

Sum({<Facturable={Y}>} Cantidad)/sum(Cantidad)

This sum is giving numbers like, 30%, 40%, 45%, etc.

What do I have to do to it to only show values that are greater or equal than 90%?

Thank you in advance.

Regards.

1 Solution

Accepted Solutions
Gysbert_Wassenaar

=If(Sum({<Facturable={Y}>} Cantidad)/sum(Cantidad)>=0.9,Sum({<Facturable={Y}>} Cantidad)/sum(Cantidad))

Or maybe:

Sum({<Facturable={Y}, MyDimension={"=Sum({<Facturable={Y}>} Cantidad)/sum(Cantidad)>=0.9"}>} Cantidad)/sum({< MyDimension={"=Sum({<Facturable={Y}>} Cantidad)/sum(Cantidad)>=0.9"}>}Cantidad)


talk is cheap, supply exceeds demand

View solution in original post

9 Replies
Gysbert_Wassenaar

=If(Sum({<Facturable={Y}>} Cantidad)/sum(Cantidad)>=0.9,Sum({<Facturable={Y}>} Cantidad)/sum(Cantidad))

Or maybe:

Sum({<Facturable={Y}, MyDimension={"=Sum({<Facturable={Y}>} Cantidad)/sum(Cantidad)>=0.9"}>} Cantidad)/sum({< MyDimension={"=Sum({<Facturable={Y}>} Cantidad)/sum(Cantidad)>=0.9"}>}Cantidad)


talk is cheap, supply exceeds demand

View solution in original post

patriciousa
Creator II
Creator II
Author

Thank you Gysbert. The first one worked like a charm. (The second one was doing nothing, keeping the same results).

However, I still have one little issue, Untitled.png

How do I delete the grey part where it has no numbers when put in a Table? I ticked to Show Nulls off but it still does.

Thank you again.

Regards.

Gysbert_Wassenaar

You need to apply the same condition to the Total Horas measure too.


talk is cheap, supply exceeds demand
patriciousa
Creator II
Creator II
Author

I'm sorry but what do you mean? Please, check the screenshot.

Untitled.png

Thank you.

Regards.

patriciousa
Creator II
Creator II
Author

If I apply the same syntaxis you gave for Total Horas I also get the grey pane. I want to make it dissapear, is it possible?.

Thank you again.

Regards.

swuehl
MVP
MVP

You need to apply the same condition and you need to disable 'Show NULL values' on Add-Ons - Data processing tab of your chart properties.

patriciousa
Creator II
Creator II
Author

Tried that swuehl.

It does nothing

Gysbert_Wassenaar

Please post a Qlik Sense app that demonstrates the problem.


talk is cheap, supply exceeds demand
patriciousa
Creator II
Creator II
Author

I don't know what I was doing wrong but applying the same expression to Total Horas fixed it after all.

Thank you very much.

Kind regards.